summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman8
1 files changed, 4 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index e91169f29..a6bbd8fa2 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1074,10 +1074,10 @@ for x in scanlist:
badlicsyntax = badlicsyntax > 0
badprovsyntax = badprovsyntax > 0
-# if not baddepsyntax:
-# if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
-# stats["usage.obsolete"] += 1
-# fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
+ if not baddepsyntax:
+ if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
+ stats["usage.obsolete"] += 1
+ fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
for keyword,arch,groups in arches: