summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman5
1 files changed, 1 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index 8834b642b..0a1a92dd8 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1078,7 +1078,7 @@ for x in scanlist:
ebuildlist=[]
pkgs = {}
for y in checkdirlist:
- if y in no_exec and \
+ if (y in no_exec or y.endswith(".ebuild")) and \
stat.S_IMODE(os.stat(os.path.join(checkdir, y)).st_mode) & 0o111:
stats["file.executable"] += 1
fails["file.executable"].append(os.path.join(checkdir, y))
@@ -1394,9 +1394,6 @@ for x in scanlist:
stats['changelog.ebuildadded'] += 1
fails['changelog.ebuildadded'].append(relative_path)
- if stat.S_IMODE(os.stat(full_path).st_mode) & 0o111:
- stats["file.executable"] += 1
- fails["file.executable"].append(x+"/"+y+".ebuild")
if vcs in ("cvs", "svn", "bzr") and check_ebuild_notadded and y not in eadded:
#ebuild not added to vcs
stats["ebuild.notadded"]=stats["ebuild.notadded"]+1