summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman10
1 files changed, 1 insertions, 9 deletions
diff --git a/bin/repoman b/bin/repoman
index 66ae10e6a..0f27e5de8 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1665,15 +1665,7 @@ else:
# It's a manifest... auto add
myautoadd+=[myunadded[x]]
del myunadded[x]
- elif len(xs[-1])>=7:
- if xs[-1][:7]=="digest-":
- del xs[-2]
- myeb="/".join(xs[:-1]+[xs[-1][7:]])+".ebuild"
- if os.path.exists(myeb):
- # Ebuild exists for digest... So autoadd it.
- myautoadd+=[myunadded[x]]
- del myunadded[x]
-
+
if myautoadd:
print ">>> Auto-Adding missing digests..."
if options.pretend: