summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ebuild.sh4
1 files changed, 4 insertions, 0 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index 173865cde..32dc64f0c 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -512,6 +512,10 @@ if ! has "$EBUILD_PHASE" clean cleanrm depend && \
[[ -n $EAPI ]] || EAPI=0
fi
+if has "${EAPI:-0}" 4-python; then
+ shopt -s globstar
+fi
+
if ! has "$EBUILD_PHASE" clean cleanrm ; then
if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
-f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \