summaryrefslogtreecommitdiffstats
path: root/pym/portage/dbapi/bintree.py
diff options
context:
space:
mode:
Diffstat (limited to 'pym/portage/dbapi/bintree.py')
-rw-r--r--pym/portage/dbapi/bintree.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/pym/portage/dbapi/bintree.py b/pym/portage/dbapi/bintree.py
index 9970ccab2..240772808 100644
--- a/pym/portage/dbapi/bintree.py
+++ b/pym/portage/dbapi/bintree.py
@@ -10,6 +10,7 @@ import portage
portage.proxy.lazyimport.lazyimport(globals(),
'portage.dep:dep_getkey,isjustname,match_from_list',
'portage.output:EOutput,colorize',
+ 'portage.package.ebuild.doebuild:_vdb_use_conditional_atoms',
'portage.update:update_dbentries',
'portage.util:ensure_dirs,normalize_path,writemsg,writemsg_stdout',
'portage.versions:best,catpkgsplit,catsplit',
@@ -1065,7 +1066,7 @@ class binarytree(object):
writemsg("%s: %s\n" % (k, str(e)),
noiselevel=-1)
raise
- if k in portage._vdb_use_conditional_atoms:
+ if k in _vdb_use_conditional_atoms:
v_split = []
for x in deps.split():
try: