summaryrefslogtreecommitdiffstats
path: root/pym/portage/tests/ebuild/test_pty_eof.py
diff options
context:
space:
mode:
Diffstat (limited to 'pym/portage/tests/ebuild/test_pty_eof.py')
-rw-r--r--pym/portage/tests/ebuild/test_pty_eof.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/pym/portage/tests/ebuild/test_pty_eof.py b/pym/portage/tests/ebuild/test_pty_eof.py
index 31a5df4aa..b29c8f95f 100644
--- a/pym/portage/tests/ebuild/test_pty_eof.py
+++ b/pym/portage/tests/ebuild/test_pty_eof.py
@@ -4,6 +4,7 @@
import portage
from portage.tests import TestCase
+from portage.package.ebuild._pty import _can_test_pty_eof, _test_pty_eof
class PtyEofTestCase(TestCase):
@@ -13,8 +14,8 @@ class PtyEofTestCase(TestCase):
# Since it might not be fixed, mark as todo.
self.todo = True
# The result is only valid if openpty does not raise EnvironmentError.
- if portage._can_test_pty_eof():
+ if _can_test_pty_eof():
try:
- self.assertEqual(portage._test_pty_eof(), True)
+ self.assertEqual(_test_pty_eof(), True)
except EnvironmentError:
pass