summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/dbapi/porttree.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/pym/portage/dbapi/porttree.py b/pym/portage/dbapi/porttree.py
index 0065ed3b8..c72e17812 100644
--- a/pym/portage/dbapi/porttree.py
+++ b/pym/portage/dbapi/porttree.py
@@ -349,9 +349,7 @@ class portdbapi(dbapi):
x.sync()
def findLicensePath(self, license_name):
- mytrees = self.porttrees[:]
- mytrees.reverse()
- for x in mytrees:
+ for x in reversed(self.porttrees):
license_path = os.path.join(x, "licenses", license_name)
if os.access(license_path, os.R_OK):
return license_path
@@ -413,8 +411,7 @@ class portdbapi(dbapi):
if mytree:
mytrees = [mytree]
else:
- mytrees = self.porttrees[:]
- mytrees.reverse()
+ mytrees = reversed(self.porttrees)
relative_path = mysplit[0] + _os.sep + psplit[0] + _os.sep + \
mysplit[1] + ".ebuild"