summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2013-06-07 14:35:28 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2013-08-13 19:59:53 +0200
commitcfccd5846c9cadcd011865f1edba0412fa1482d0 (patch)
treed8ac61b38078435ed16e299020980ce6882a1c32 /Makefile
parent9226a50fea7841c6ec57437b604ab328b951cc2c (diff)
downloadhostinfo-maintainer-debian/0.1.4.tar.gz
hostinfo-maintainer-debian/0.1.4.tar.bz2
hostinfo-maintainer-debian/0.1.4.zip
debian: debianizationdebian/0.1.4
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a178da3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
+
+all:
+ cp -a missing-maintainer-keys.in missing-maintainer-keys
+ sed -i 's/__VERSION__/$(VERSION)/' missing-maintainer-keys
+
+clean:
+ $(RM) missing-maintainer-keys
+
+install:
+ install -D missing-maintainer-keys $(DESTDIR)/usr/lib/nagios/plugins/missing-maintainer-keys