summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a178da3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
+
+all:
+ cp -a missing-maintainer-keys.in missing-maintainer-keys
+ sed -i 's/__VERSION__/$(VERSION)/' missing-maintainer-keys
+
+clean:
+ $(RM) missing-maintainer-keys
+
+install:
+ install -D missing-maintainer-keys $(DESTDIR)/usr/lib/nagios/plugins/missing-maintainer-keys