summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-28 22:54:53 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-28 22:54:53 +0200
commit1b83929487f797b0b0960b89fb5cbdc8c216ba96 (patch)
tree56b881182b63183461706ace0dac4932e45545ad
parentb06c663bc2976940e3a5aa17b6d2c314a908f697 (diff)
downloadcolobot-1b83929487f797b0b0960b89fb5cbdc8c216ba96.tar.gz
colobot-1b83929487f797b0b0960b89fb5cbdc8c216ba96.tar.bz2
colobot-1b83929487f797b0b0960b89fb5cbdc8c216ba96.zip
Pulled changes from master branch
-rw-r--r--src/CBot/CBotString.cpp2
-rw-r--r--src/CBot/CMakeLists.txt1
-rw-r--r--src/common/profile.cpp12
-rw-r--r--src/common/profile.h12
-rw-r--r--src/object/robotmain.cpp44
-rw-r--r--src/ui/maindialog.cpp162
6 files changed, 117 insertions, 116 deletions
diff --git a/src/CBot/CBotString.cpp b/src/CBot/CBotString.cpp
index 2a1e3bd..53b0f27 100644
--- a/src/CBot/CBotString.cpp
+++ b/src/CBot/CBotString.cpp
@@ -21,7 +21,7 @@
#include <string.h>
-HINSTANCE CBotString::m_hInstance = (HINSTANCE)LoadLibrary("Cbot.dll"); // comment le récupérer autrement ??
+HINSTANCE CBotString::m_hInstance = (HINSTANCE)LoadLibrary("libCbot.dll"); // comment le récupérer autrement ??
CBotString::CBotString()
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index 409ef3b..9933e9c 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -10,6 +10,7 @@ CBotToken.cpp
CBotTwoOpExpr.cpp
CBotVar.cpp
CBotWhile.cpp
+CBot.rc
)
add_library(CBot SHARED ${SOURCES})
diff --git a/src/common/profile.cpp b/src/common/profile.cpp
index 07dafae..d921d34 100644
--- a/src/common/profile.cpp
+++ b/src/common/profile.cpp
@@ -42,13 +42,13 @@ bool InitCurrentDirectory()
}
-bool SetProfileString(char* section, char* key, char* string)
+bool SetLocalProfileString(char* section, char* key, char* string)
{
WritePrivateProfileString(section, key, string, g_filename);
return true;
}
-bool GetProfileString(char* section, char* key, char* buffer, int max)
+bool GetLocalProfileString(char* section, char* key, char* buffer, int max)
{
int nb;
@@ -62,7 +62,7 @@ bool GetProfileString(char* section, char* key, char* buffer, int max)
}
-bool SetProfileInt(char* section, char* key, int value)
+bool SetLocalProfileInt(char* section, char* key, int value)
{
char s[20];
@@ -71,7 +71,7 @@ bool SetProfileInt(char* section, char* key, int value)
return true;
}
-bool GetProfileInt(char* section, char* key, int &value)
+bool GetLocalProfileInt(char* section, char* key, int &value)
{
char s[20];
int nb;
@@ -87,7 +87,7 @@ bool GetProfileInt(char* section, char* key, int &value)
}
-bool SetProfileFloat(char* section, char* key, float value)
+bool SetLocalProfileFloat(char* section, char* key, float value)
{
char s[20];
@@ -96,7 +96,7 @@ bool SetProfileFloat(char* section, char* key, float value)
return true;
}
-bool GetProfileFloat(char* section, char* key, float &value)
+bool GetLocalProfileFloat(char* section, char* key, float &value)
{
char s[20];
int nb;
diff --git a/src/common/profile.h b/src/common/profile.h
index 1a36050..2c76a0b 100644
--- a/src/common/profile.h
+++ b/src/common/profile.h
@@ -20,11 +20,11 @@
extern bool InitCurrentDirectory();
-extern bool SetProfileString(char* section, char* key, char* string);
-extern bool GetProfileString(char* section, char* key, char* buffer, int max);
-extern bool SetProfileInt(char* section, char* key, int value);
-extern bool GetProfileInt(char* section, char* key, int &value);
-extern bool SetProfileFloat(char* section, char* key, float value);
-extern bool GetProfileFloat(char* section, char* key, float &value);
+extern bool SetLocalProfileString(char* section, char* key, char* string);
+extern bool GetLocalProfileString(char* section, char* key, char* buffer, int max);
+extern bool SetLocalProfileInt(char* section, char* key, int value);
+extern bool GetLocalProfileInt(char* section, char* key, int &value);
+extern bool SetLocalProfileFloat(char* section, char* key, float value);
+extern bool GetLocalProfileFloat(char* section, char* key, float &value);
diff --git a/src/object/robotmain.cpp b/src/object/robotmain.cpp
index 1929f6d..1b213f2 100644
--- a/src/object/robotmain.cpp
+++ b/src/object/robotmain.cpp
@@ -283,22 +283,22 @@ CRobotMain::CRobotMain(CInstanceManager* iMan)
m_windowPos = Math::Point(0.15f, 0.17f);
m_windowDim = Math::Point(0.70f, 0.66f);
- if ( GetProfileFloat("Edit", "FontSize", fValue) ) m_fontSize = fValue;
- if ( GetProfileFloat("Edit", "WindowPos.x", fValue) ) m_windowPos.x = fValue;
- if ( GetProfileFloat("Edit", "WindowPos.y", fValue) ) m_windowPos.y = fValue;
- if ( GetProfileFloat("Edit", "WindowDim.x", fValue) ) m_windowDim.x = fValue;
- if ( GetProfileFloat("Edit", "WindowDim.y", fValue) ) m_windowDim.y = fValue;
+ if ( GetLocalProfileFloat("Edit", "FontSize", fValue) ) m_fontSize = fValue;
+ if ( GetLocalProfileFloat("Edit", "WindowPos.x", fValue) ) m_windowPos.x = fValue;
+ if ( GetLocalProfileFloat("Edit", "WindowPos.y", fValue) ) m_windowPos.y = fValue;
+ if ( GetLocalProfileFloat("Edit", "WindowDim.x", fValue) ) m_windowDim.x = fValue;
+ if ( GetLocalProfileFloat("Edit", "WindowDim.y", fValue) ) m_windowDim.y = fValue;
m_IOPublic = false;
m_IODim = Math::Point(320.0f/640.0f, (121.0f+18.0f*8)/480.0f);
m_IOPos.x = (1.0f-m_IODim.x)/2.0f; // in the middle
m_IOPos.y = (1.0f-m_IODim.y)/2.0f;
- if ( GetProfileInt ("Edit", "IOPublic", iValue) ) m_IOPublic = iValue;
- if ( GetProfileFloat("Edit", "IOPos.x", fValue) ) m_IOPos.x = fValue;
- if ( GetProfileFloat("Edit", "IOPos.y", fValue) ) m_IOPos.y = fValue;
- if ( GetProfileFloat("Edit", "IODim.x", fValue) ) m_IODim.x = fValue;
- if ( GetProfileFloat("Edit", "IODim.y", fValue) ) m_IODim.y = fValue;
+ if ( GetLocalProfileInt ("Edit", "IOPublic", iValue) ) m_IOPublic = iValue;
+ if ( GetLocalProfileFloat("Edit", "IOPos.x", fValue) ) m_IOPos.x = fValue;
+ if ( GetLocalProfileFloat("Edit", "IOPos.y", fValue) ) m_IOPos.y = fValue;
+ if ( GetLocalProfileFloat("Edit", "IODim.x", fValue) ) m_IODim.x = fValue;
+ if ( GetLocalProfileFloat("Edit", "IODim.y", fValue) ) m_IODim.y = fValue;
m_short->FlushShortcuts();
InitEye();
@@ -315,7 +315,7 @@ CRobotMain::CRobotMain(CInstanceManager* iMan)
g_unit = 4.0f;
m_gamerName[0] = 0;
- GetProfileString("Gamer", "LastName", m_gamerName, 100);
+ GetLocalProfileString("Gamer", "LastName", m_gamerName, 100);
SetGlobalGamerName(m_gamerName);
ReadFreeParam();
m_dialog->SetupRecall();
@@ -430,7 +430,7 @@ void CRobotMain::CreateIni()
int iValue;
// colobot.ini don't exist?
- if ( !GetProfileInt("Setup", "TotoMode", iValue) )
+ if ( !GetLocalProfileInt("Setup", "TotoMode", iValue) )
{
m_dialog->SetupMemorize();
}
@@ -1801,7 +1801,7 @@ float CRobotMain::RetGameTime()
void CRobotMain::SetFontSize(float size)
{
m_fontSize = size;
- SetProfileFloat("Edit", "FontSize", m_fontSize);
+ SetLocalProfileFloat("Edit", "FontSize", m_fontSize);
}
float CRobotMain::RetFontSize()
@@ -1814,8 +1814,8 @@ float CRobotMain::RetFontSize()
void CRobotMain::SetWindowPos(Math::Point pos)
{
m_windowPos = pos;
- SetProfileFloat("Edit", "WindowPos.x", m_windowPos.x);
- SetProfileFloat("Edit", "WindowPos.y", m_windowPos.y);
+ SetLocalProfileFloat("Edit", "WindowPos.x", m_windowPos.x);
+ SetLocalProfileFloat("Edit", "WindowPos.y", m_windowPos.y);
}
Math::Point CRobotMain::RetWindowPos()
@@ -1826,8 +1826,8 @@ Math::Point CRobotMain::RetWindowPos()
void CRobotMain::SetWindowDim(Math::Point dim)
{
m_windowDim = dim;
- SetProfileFloat("Edit", "WindowDim.x", m_windowDim.x);
- SetProfileFloat("Edit", "WindowDim.y", m_windowDim.y);
+ SetLocalProfileFloat("Edit", "WindowDim.x", m_windowDim.x);
+ SetLocalProfileFloat("Edit", "WindowDim.y", m_windowDim.y);
}
Math::Point CRobotMain::RetWindowDim()
@@ -1841,7 +1841,7 @@ Math::Point CRobotMain::RetWindowDim()
void CRobotMain::SetIOPublic(bool bMode)
{
m_IOPublic = bMode;
- SetProfileInt("Edit", "IOPublic", m_IOPublic);
+ SetLocalProfileInt("Edit", "IOPublic", m_IOPublic);
}
bool CRobotMain::RetIOPublic()
@@ -1852,8 +1852,8 @@ bool CRobotMain::RetIOPublic()
void CRobotMain::SetIOPos(Math::Point pos)
{
m_IOPos = pos;
- SetProfileFloat("Edit", "IOPos.x", m_IOPos.x);
- SetProfileFloat("Edit", "IOPos.y", m_IOPos.y);
+ SetLocalProfileFloat("Edit", "IOPos.x", m_IOPos.x);
+ SetLocalProfileFloat("Edit", "IOPos.y", m_IOPos.y);
}
Math::Point CRobotMain::RetIOPos()
@@ -1864,8 +1864,8 @@ Math::Point CRobotMain::RetIOPos()
void CRobotMain::SetIODim(Math::Point dim)
{
m_IODim = dim;
- SetProfileFloat("Edit", "IODim.x", m_IODim.x);
- SetProfileFloat("Edit", "IODim.y", m_IODim.y);
+ SetLocalProfileFloat("Edit", "IODim.x", m_IODim.x);
+ SetLocalProfileFloat("Edit", "IODim.y", m_IODim.y);
}
Math::Point CRobotMain::RetIODim()
diff --git a/src/ui/maindialog.cpp b/src/ui/maindialog.cpp
index 5d96043..c8759e0 100644
--- a/src/ui/maindialog.cpp
+++ b/src/ui/maindialog.cpp
@@ -3884,7 +3884,7 @@ void CMainDialog::NameSelect()
RetGamerFace(m_main->RetGamerName());
- SetProfileString("Gamer", "LastName", m_main->RetGamerName());
+ SetLocalProfileString("Gamer", "LastName", m_main->RetGamerName());
}
// Creates a new player.
@@ -5522,104 +5522,104 @@ void CMainDialog::SetupMemorize()
char key[500];
char num[10];
- SetProfileString("Directory", "scene", m_sceneDir);
- SetProfileString("Directory", "savegame", m_savegameDir);
- SetProfileString("Directory", "public", m_publicDir);
- SetProfileString("Directory", "user", m_userDir);
- SetProfileString("Directory", "files", m_filesDir);
+ SetLocalProfileString("Directory", "scene", m_sceneDir);
+ SetLocalProfileString("Directory", "savegame", m_savegameDir);
+ SetLocalProfileString("Directory", "public", m_publicDir);
+ SetLocalProfileString("Directory", "user", m_userDir);
+ SetLocalProfileString("Directory", "files", m_filesDir);
iValue = m_engine->RetTotoMode();
- SetProfileInt("Setup", "TotoMode", iValue);
+ SetLocalProfileInt("Setup", "TotoMode", iValue);
iValue = m_bTooltip;
- SetProfileInt("Setup", "Tooltips", iValue);
+ SetLocalProfileInt("Setup", "Tooltips", iValue);
iValue = m_bGlint;
- SetProfileInt("Setup", "InterfaceGlint", iValue);
+ SetLocalProfileInt("Setup", "InterfaceGlint", iValue);
iValue = m_bRain;
- SetProfileInt("Setup", "InterfaceGlint", iValue);
+ SetLocalProfileInt("Setup", "InterfaceGlint", iValue);
iValue = m_engine->RetNiceMouse();
- SetProfileInt("Setup", "NiceMouse", iValue);
+ SetLocalProfileInt("Setup", "NiceMouse", iValue);
iValue = m_bSoluce4;
- SetProfileInt("Setup", "Soluce4", iValue);
+ SetLocalProfileInt("Setup", "Soluce4", iValue);
iValue = m_bMovies;
- SetProfileInt("Setup", "Movies", iValue);
+ SetLocalProfileInt("Setup", "Movies", iValue);
iValue = m_bNiceReset;
- SetProfileInt("Setup", "NiceReset", iValue);
+ SetLocalProfileInt("Setup", "NiceReset", iValue);
iValue = m_bHimselfDamage;
- SetProfileInt("Setup", "HimselfDamage", iValue);
+ SetLocalProfileInt("Setup", "HimselfDamage", iValue);
iValue = m_bCameraScroll;
- SetProfileInt("Setup", "CameraScroll", iValue);
+ SetLocalProfileInt("Setup", "CameraScroll", iValue);
iValue = m_bCameraInvertX;
- SetProfileInt("Setup", "CameraInvertX", iValue);
+ SetLocalProfileInt("Setup", "CameraInvertX", iValue);
iValue = m_bEffect;
- SetProfileInt("Setup", "InterfaceEffect", iValue);
+ SetLocalProfileInt("Setup", "InterfaceEffect", iValue);
iValue = m_engine->RetShadow();
- SetProfileInt("Setup", "GroundShadow", iValue);
+ SetLocalProfileInt("Setup", "GroundShadow", iValue);
iValue = m_engine->RetGroundSpot();
- SetProfileInt("Setup", "GroundSpot", iValue);
+ SetLocalProfileInt("Setup", "GroundSpot", iValue);
iValue = m_engine->RetDirty();
- SetProfileInt("Setup", "ObjectDirty", iValue);
+ SetLocalProfileInt("Setup", "ObjectDirty", iValue);
iValue = m_engine->RetFog();
- SetProfileInt("Setup", "FogMode", iValue);
+ SetLocalProfileInt("Setup", "FogMode", iValue);
iValue = m_engine->RetLensMode();
- SetProfileInt("Setup", "LensMode", iValue);
+ SetLocalProfileInt("Setup", "LensMode", iValue);
iValue = m_engine->RetSkyMode();
- SetProfileInt("Setup", "SkyMode", iValue);
+ SetLocalProfileInt("Setup", "SkyMode", iValue);
iValue = m_engine->RetPlanetMode();
- SetProfileInt("Setup", "PlanetMode", iValue);
+ SetLocalProfileInt("Setup", "PlanetMode", iValue);
iValue = m_engine->RetLightMode();
- SetProfileInt("Setup", "LightMode", iValue);
+ SetLocalProfileInt("Setup", "LightMode", iValue);
iValue = m_engine->RetJoystick();
- SetProfileInt("Setup", "UseJoystick", iValue);
+ SetLocalProfileInt("Setup", "UseJoystick", iValue);
fValue = m_engine->RetParticuleDensity();
- SetProfileFloat("Setup", "ParticuleDensity", fValue);
+ SetLocalProfileFloat("Setup", "ParticuleDensity", fValue);
fValue = m_engine->RetClippingDistance();
- SetProfileFloat("Setup", "ClippingDistance", fValue);
+ SetLocalProfileFloat("Setup", "ClippingDistance", fValue);
fValue = m_engine->RetObjectDetail();
- SetProfileFloat("Setup", "ObjectDetail", fValue);
+ SetLocalProfileFloat("Setup", "ObjectDetail", fValue);
fValue = m_engine->RetGadgetQuantity();
- SetProfileFloat("Setup", "GadgetQuantity", fValue);
+ SetLocalProfileFloat("Setup", "GadgetQuantity", fValue);
iValue = m_engine->RetTextureQuality();
- SetProfileInt("Setup", "TextureQuality", iValue);
+ SetLocalProfileInt("Setup", "TextureQuality", iValue);
iValue = m_sound->RetAudioVolume();
- SetProfileInt("Setup", "AudioVolume", iValue);
+ SetLocalProfileInt("Setup", "AudioVolume", iValue);
iValue = m_sound->RetMidiVolume();
- SetProfileInt("Setup", "MidiVolume", iValue);
+ SetLocalProfileInt("Setup", "MidiVolume", iValue);
iValue = m_sound->RetSound3D();
- SetProfileInt("Setup", "Sound3D", iValue);
+ SetLocalProfileInt("Setup", "Sound3D", iValue);
iValue = m_engine->RetEditIndentMode();
- SetProfileInt("Setup", "EditIndentMode", iValue);
+ SetLocalProfileInt("Setup", "EditIndentMode", iValue);
iValue = m_engine->RetEditIndentValue();
- SetProfileInt("Setup", "EditIndentValue", iValue);
+ SetLocalProfileInt("Setup", "EditIndentValue", iValue);
key[0] = 0;
for ( i=0 ; i<100 ; i++ )
@@ -5633,21 +5633,21 @@ void CMainDialog::SetupMemorize()
strcat(key, num);
}
}
- SetProfileString("Setup", "KeyMap", key);
+ SetLocalProfileString("Setup", "KeyMap", key);
#if _NET
if ( m_accessEnable )
{
iValue = m_accessMission;
- SetProfileInt("Setup", "AccessMission", iValue);
+ SetLocalProfileInt("Setup", "AccessMission", iValue);
iValue = m_accessUser;
- SetProfileInt("Setup", "AccessUser", iValue);
+ SetLocalProfileInt("Setup", "AccessUser", iValue);
}
#endif
iValue = m_bDeleteGamer;
- SetProfileInt("Setup", "DeleteGamer", iValue);
+ SetLocalProfileInt("Setup", "DeleteGamer", iValue);
m_engine->WriteProfile();
}
@@ -5661,192 +5661,192 @@ void CMainDialog::SetupRecall()
char key[500];
char* p;
- if ( GetProfileString("Directory", "scene", key, _MAX_FNAME) )
+ if ( GetLocalProfileString("Directory", "scene", key, _MAX_FNAME) )
{
strcpy(m_sceneDir, key);
}
- if ( GetProfileString("Directory", "savegame", key, _MAX_FNAME) )
+ if ( GetLocalProfileString("Directory", "savegame", key, _MAX_FNAME) )
{
strcpy(m_savegameDir, key);
}
- if ( GetProfileString("Directory", "public", key, _MAX_FNAME) )
+ if ( GetLocalProfileString("Directory", "public", key, _MAX_FNAME) )
{
strcpy(m_publicDir, key);
}
- if ( GetProfileString("Directory", "user", key, _MAX_FNAME) )
+ if ( GetLocalProfileString("Directory", "user", key, _MAX_FNAME) )
{
strcpy(m_userDir, key);
}
- if ( GetProfileString("Directory", "files", key, _MAX_FNAME) )
+ if ( GetLocalProfileString("Directory", "files", key, _MAX_FNAME) )
{
strcpy(m_filesDir, key);
}
- if ( GetProfileInt("Setup", "TotoMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "TotoMode", iValue) )
{
m_engine->SetTotoMode(iValue);
}
- if ( GetProfileInt("Setup", "Tooltips", iValue) )
+ if ( GetLocalProfileInt("Setup", "Tooltips", iValue) )
{
m_bTooltip = iValue;
}
- if ( GetProfileInt("Setup", "InterfaceGlint", iValue) )
+ if ( GetLocalProfileInt("Setup", "InterfaceGlint", iValue) )
{
m_bGlint = iValue;
}
- if ( GetProfileInt("Setup", "InterfaceGlint", iValue) )
+ if ( GetLocalProfileInt("Setup", "InterfaceGlint", iValue) )
{
m_bRain = iValue;
}
- if ( GetProfileInt("Setup", "NiceMouse", iValue) )
+ if ( GetLocalProfileInt("Setup", "NiceMouse", iValue) )
{
m_engine->SetNiceMouse(iValue);
}
- if ( GetProfileInt("Setup", "Soluce4", iValue) )
+ if ( GetLocalProfileInt("Setup", "Soluce4", iValue) )
{
m_bSoluce4 = iValue;
}
- if ( GetProfileInt("Setup", "Movies", iValue) )
+ if ( GetLocalProfileInt("Setup", "Movies", iValue) )
{
m_bMovies = iValue;
}
- if ( GetProfileInt("Setup", "NiceReset", iValue) )
+ if ( GetLocalProfileInt("Setup", "NiceReset", iValue) )
{
m_bNiceReset = iValue;
}
- if ( GetProfileInt("Setup", "HimselfDamage", iValue) )
+ if ( GetLocalProfileInt("Setup", "HimselfDamage", iValue) )
{
m_bHimselfDamage = iValue;
}
- if ( GetProfileInt("Setup", "CameraScroll", iValue) )
+ if ( GetLocalProfileInt("Setup", "CameraScroll", iValue) )
{
m_bCameraScroll = iValue;
m_camera->SetCameraScroll(m_bCameraScroll);
}
- if ( GetProfileInt("Setup", "CameraInvertX", iValue) )
+ if ( GetLocalProfileInt("Setup", "CameraInvertX", iValue) )
{
m_bCameraInvertX = iValue;
m_camera->SetCameraInvertX(m_bCameraInvertX);
}
- if ( GetProfileInt("Setup", "CameraInvertY", iValue) )
+ if ( GetLocalProfileInt("Setup", "CameraInvertY", iValue) )
{
m_bCameraInvertY = iValue;
m_camera->SetCameraInvertY(m_bCameraInvertY);
}
- if ( GetProfileInt("Setup", "InterfaceEffect", iValue) )
+ if ( GetLocalProfileInt("Setup", "InterfaceEffect", iValue) )
{
m_bEffect = iValue;
}
- if ( GetProfileInt("Setup", "GroundShadow", iValue) )
+ if ( GetLocalProfileInt("Setup", "GroundShadow", iValue) )
{
m_engine->SetShadow(iValue);
}
- if ( GetProfileInt("Setup", "GroundSpot", iValue) )
+ if ( GetLocalProfileInt("Setup", "GroundSpot", iValue) )
{
m_engine->SetGroundSpot(iValue);
}
- if ( GetProfileInt("Setup", "ObjectDirty", iValue) )
+ if ( GetLocalProfileInt("Setup", "ObjectDirty", iValue) )
{
m_engine->SetDirty(iValue);
}
- if ( GetProfileInt("Setup", "FogMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "FogMode", iValue) )
{
m_engine->SetFog(iValue);
m_camera->SetOverBaseColor(RetColor(RetColor(0.0f)));
}
- if ( GetProfileInt("Setup", "LensMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "LensMode", iValue) )
{
m_engine->SetLensMode(iValue);
}
- if ( GetProfileInt("Setup", "SkyMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "SkyMode", iValue) )
{
m_engine->SetSkyMode(iValue);
}
- if ( GetProfileInt("Setup", "PlanetMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "PlanetMode", iValue) )
{
m_engine->SetPlanetMode(iValue);
}
- if ( GetProfileInt("Setup", "LightMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "LightMode", iValue) )
{
m_engine->SetLightMode(iValue);
}
- if ( GetProfileInt("Setup", "UseJoystick", iValue) )
+ if ( GetLocalProfileInt("Setup", "UseJoystick", iValue) )
{
m_engine->SetJoystick(iValue);
}
- if ( GetProfileFloat("Setup", "ParticuleDensity", fValue) )
+ if ( GetLocalProfileFloat("Setup", "ParticuleDensity", fValue) )
{
m_engine->SetParticuleDensity(fValue);
}
- if ( GetProfileFloat("Setup", "ClippingDistance", fValue) )
+ if ( GetLocalProfileFloat("Setup", "ClippingDistance", fValue) )
{
m_engine->SetClippingDistance(fValue);
}
- if ( GetProfileFloat("Setup", "ObjectDetail", fValue) )
+ if ( GetLocalProfileFloat("Setup", "ObjectDetail", fValue) )
{
m_engine->SetObjectDetail(fValue);
}
- if ( GetProfileFloat("Setup", "GadgetQuantity", fValue) )
+ if ( GetLocalProfileFloat("Setup", "GadgetQuantity", fValue) )
{
m_engine->SetGadgetQuantity(fValue);
}
- if ( GetProfileInt("Setup", "TextureQuality", iValue) )
+ if ( GetLocalProfileInt("Setup", "TextureQuality", iValue) )
{
m_engine->SetTextureQuality(iValue);
}
- if ( GetProfileInt("Setup", "AudioVolume", iValue) )
+ if ( GetLocalProfileInt("Setup", "AudioVolume", iValue) )
{
m_sound->SetAudioVolume(iValue);
}
- if ( GetProfileInt("Setup", "MidiVolume", iValue) )
+ if ( GetLocalProfileInt("Setup", "MidiVolume", iValue) )
{
m_sound->SetMidiVolume(iValue);
}
- if ( GetProfileInt("Setup", "EditIndentMode", iValue) )
+ if ( GetLocalProfileInt("Setup", "EditIndentMode", iValue) )
{
m_engine->SetEditIndentMode(iValue);
}
- if ( GetProfileInt("Setup", "EditIndentValue", iValue) )
+ if ( GetLocalProfileInt("Setup", "EditIndentValue", iValue) )
{
m_engine->SetEditIndentValue(iValue);
}
- if ( GetProfileString("Setup", "KeyMap", key, 500) )
+ if ( GetLocalProfileString("Setup", "KeyMap", key, 500) )
{
p = key;
for ( i=0 ; i<100 ; i++ )
@@ -5866,19 +5866,19 @@ void CMainDialog::SetupRecall()
#if _NET
if ( m_accessEnable )
{
- if ( GetProfileInt("Setup", "AccessMission", iValue) )
+ if ( GetLocalProfileInt("Setup", "AccessMission", iValue) )
{
m_accessMission = iValue;
}
- if ( GetProfileInt("Setup", "AccessUser", iValue) )
+ if ( GetLocalProfileInt("Setup", "AccessUser", iValue) )
{
m_accessUser = iValue;
}
}
#endif
- if ( GetProfileInt("Setup", "DeleteGamer", iValue) )
+ if ( GetLocalProfileInt("Setup", "DeleteGamer", iValue) )
{
m_bDeleteGamer = iValue;
}