summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-07-26 22:26:19 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-07-26 22:26:19 +0200
commit4ddcd9f810fa588ccf90442f7b4e5ddf385e85f2 (patch)
tree04cd5a00e080407ed243042e2dd7efe4ba94d4f8
parent045f17a274c0cd41aebd34d5759f7fe791b680e4 (diff)
downloadcolobot-4ddcd9f810fa588ccf90442f7b4e5ddf385e85f2.tar.gz
colobot-4ddcd9f810fa588ccf90442f7b4e5ddf385e85f2.tar.bz2
colobot-4ddcd9f810fa588ccf90442f7b4e5ddf385e85f2.zip
Change of paths in src/graphics
- moved abstract core to src/graphics/core - moved proper graphics engine to src/graphics/engine
-rw-r--r--src/CMakeLists.txt26
-rw-r--r--src/app/app.h4
-rw-r--r--src/graphics/common/README.txt5
-rw-r--r--src/graphics/core/README.txt6
-rw-r--r--src/graphics/core/color.cpp (renamed from src/graphics/common/color.cpp)2
-rw-r--r--src/graphics/core/color.h (renamed from src/graphics/common/color.h)0
-rw-r--r--src/graphics/core/device.h (renamed from src/graphics/common/device.h)10
-rw-r--r--src/graphics/core/light.h91
-rw-r--r--src/graphics/core/material.h (renamed from src/graphics/common/material.h)2
-rw-r--r--src/graphics/core/texture.h (renamed from src/graphics/common/texture.h)0
-rw-r--r--src/graphics/core/vertex.h (renamed from src/graphics/common/vertex.h)2
-rw-r--r--src/graphics/engine/README.txt8
-rw-r--r--src/graphics/engine/camera.cpp (renamed from src/graphics/common/camera.cpp)2
-rw-r--r--src/graphics/engine/camera.h (renamed from src/graphics/common/camera.h)0
-rw-r--r--src/graphics/engine/cloud.cpp (renamed from src/graphics/common/cloud.cpp)2
-rw-r--r--src/graphics/engine/cloud.h (renamed from src/graphics/common/cloud.h)2
-rw-r--r--src/graphics/engine/engine.cpp (renamed from src/graphics/common/engine.cpp)4
-rw-r--r--src/graphics/engine/engine.h (renamed from src/graphics/common/engine.h)8
-rw-r--r--src/graphics/engine/lightman.cpp (renamed from src/graphics/common/light.cpp)4
-rw-r--r--src/graphics/engine/lightman.h (renamed from src/graphics/common/light.h)69
-rw-r--r--src/graphics/engine/lightning.cpp (renamed from src/graphics/common/lightning.cpp)2
-rw-r--r--src/graphics/engine/lightning.h (renamed from src/graphics/common/lightning.h)0
-rw-r--r--src/graphics/engine/modelfile.cpp (renamed from src/graphics/common/modelfile.cpp)2
-rw-r--r--src/graphics/engine/modelfile.h (renamed from src/graphics/common/modelfile.h)6
-rw-r--r--src/graphics/engine/particle.cpp (renamed from src/graphics/common/particle.cpp)2
-rw-r--r--src/graphics/engine/particle.h (renamed from src/graphics/common/particle.h)0
-rw-r--r--src/graphics/engine/planet.cpp (renamed from src/graphics/common/planet.cpp)2
-rw-r--r--src/graphics/engine/planet.h (renamed from src/graphics/common/planet.h)0
-rw-r--r--src/graphics/engine/pyro.cpp (renamed from src/graphics/common/pyro.cpp)2
-rw-r--r--src/graphics/engine/pyro.h (renamed from src/graphics/common/pyro.h)2
-rw-r--r--src/graphics/engine/terrain.cpp (renamed from src/graphics/common/terrain.cpp)2
-rw-r--r--src/graphics/engine/terrain.h (renamed from src/graphics/common/terrain.h)2
-rw-r--r--src/graphics/engine/test/CMakeLists.txt (renamed from src/graphics/common/test/CMakeLists.txt)0
-rw-r--r--src/graphics/engine/test/modelfile_test.cpp (renamed from src/graphics/common/test/modelfile_test.cpp)2
-rw-r--r--src/graphics/engine/text.cpp (renamed from src/graphics/common/text.cpp)2
-rw-r--r--src/graphics/engine/text.h (renamed from src/graphics/common/text.h)4
-rw-r--r--src/graphics/engine/water.cpp (renamed from src/graphics/common/water.cpp)2
-rw-r--r--src/graphics/engine/water.h (renamed from src/graphics/common/water.h)4
-rw-r--r--src/graphics/opengl/README.txt4
-rw-r--r--src/graphics/opengl/gldevice.h2
-rw-r--r--src/graphics/opengl/test/CMakeLists.txt4
-rw-r--r--src/graphics/opengl/test/model_test.cpp2
42 files changed, 167 insertions, 128 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 06f5990..76a10e9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -43,19 +43,19 @@ common/iman.cpp
# common/profile.cpp
# common/restext.cpp
common/stringutils.cpp
-graphics/common/camera.cpp
-graphics/common/cloud.cpp
-graphics/common/color.cpp
-graphics/common/engine.cpp
-graphics/common/light.cpp
-graphics/common/lightning.cpp
-graphics/common/modelfile.cpp
-graphics/common/particle.cpp
-graphics/common/planet.cpp
-graphics/common/pyro.cpp
-graphics/common/terrain.cpp
-graphics/common/text.cpp
-graphics/common/water.cpp
+graphics/core/color.cpp
+graphics/engine/camera.cpp
+graphics/engine/cloud.cpp
+graphics/engine/engine.cpp
+graphics/engine/lightman.cpp
+graphics/engine/lightning.cpp
+graphics/engine/modelfile.cpp
+graphics/engine/particle.cpp
+graphics/engine/planet.cpp
+graphics/engine/pyro.cpp
+graphics/engine/terrain.cpp
+graphics/engine/text.cpp
+graphics/engine/water.cpp
graphics/opengl/gldevice.cpp
# object/auto/auto.cpp
# object/auto/autobase.cpp
diff --git a/src/app/app.h b/src/app/app.h
index 576ed62..956eab8 100644
--- a/src/app/app.h
+++ b/src/app/app.h
@@ -22,8 +22,8 @@
#include "common/misc.h"
#include "common/singleton.h"
-#include "graphics/common/device.h"
-#include "graphics/common/engine.h"
+#include "graphics/core/device.h"
+#include "graphics/engine/engine.h"
#include <string>
#include <vector>
diff --git a/src/graphics/common/README.txt b/src/graphics/common/README.txt
deleted file mode 100644
index 495a453..0000000
--- a/src/graphics/common/README.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-src/graphics/common
-
-Universal structs and classes used in graphics engine
-
-Concrete implementation in OpenGL is in graphics/opengl directory.
diff --git a/src/graphics/core/README.txt b/src/graphics/core/README.txt
new file mode 100644
index 0000000..12beef9
--- /dev/null
+++ b/src/graphics/core/README.txt
@@ -0,0 +1,6 @@
+src/graphics/core
+
+Abstract core of graphics engine
+
+Core types, enums, structs and CDevice abstract class that define
+the abstract graphics device used in graphics engine
diff --git a/src/graphics/common/color.cpp b/src/graphics/core/color.cpp
index c1b7337..8dec0e4 100644
--- a/src/graphics/common/color.cpp
+++ b/src/graphics/core/color.cpp
@@ -16,7 +16,7 @@
// color.cpp
-#include "graphics/common/color.h"
+#include "graphics/core/color.h"
#include "math/func.h"
diff --git a/src/graphics/common/color.h b/src/graphics/core/color.h
index 907a3b9..907a3b9 100644
--- a/src/graphics/common/color.h
+++ b/src/graphics/core/color.h
diff --git a/src/graphics/common/device.h b/src/graphics/core/device.h
index 7aa4ce3..ae612b7 100644
--- a/src/graphics/common/device.h
+++ b/src/graphics/core/device.h
@@ -20,11 +20,11 @@
#pragma once
-#include "graphics/common/color.h"
-#include "graphics/common/light.h"
-#include "graphics/common/material.h"
-#include "graphics/common/texture.h"
-#include "graphics/common/vertex.h"
+#include "graphics/core/color.h"
+#include "graphics/core/light.h"
+#include "graphics/core/material.h"
+#include "graphics/core/texture.h"
+#include "graphics/core/vertex.h"
#include "math/matrix.h"
#include <string>
diff --git a/src/graphics/core/light.h b/src/graphics/core/light.h
new file mode 100644
index 0000000..b787cb2
--- /dev/null
+++ b/src/graphics/core/light.h
@@ -0,0 +1,91 @@
+// * This file is part of the COLOBOT source code
+// * Copyright (C) 2001-2008, Daniel ROUX & EPSITEC SA, www.epsitec.ch
+// * Copyright (C) 2012, Polish Portal of Colobot (PPC)
+// *
+// * This program is free software: you can redistribute it and/or modify
+// * it under the terms of the GNU General Public License as published by
+// * the Free Software Foundation, either version 3 of the License, or
+// * (at your option) any later version.
+// *
+// * This program is distributed in the hope that it will be useful,
+// * but WITHOUT ANY WARRANTY; without even the implied warranty of
+// * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// * GNU General Public License for more details.
+// *
+// * You should have received a copy of the GNU General Public License
+// * along with this program. If not, see http://www.gnu.org/licenses/.
+
+// light.h
+
+#pragma once
+
+
+#include "graphics/core/color.h"
+#include "math/vector.h"
+
+
+namespace Gfx {
+
+/**
+ \enum LightType
+ \brief Type of light in 3D scene */
+enum LightType
+{
+ LIGHT_POINT,
+ LIGHT_SPOT,
+ LIGHT_DIRECTIONAL
+};
+
+/**
+ \struct Light
+ \brief Properties of light in 3D scene
+
+ This structure was created as analog to DirectX's D3DLIGHT. */
+struct Light
+{
+ //! Type of light source
+ Gfx::LightType type;
+ //! Color of ambient light
+ Gfx::Color ambient;
+ //! Color of diffuse light
+ Gfx::Color diffuse;
+ //! Color of specular light
+ Gfx::Color specular;
+ //! Position in world space (for point & spot lights)
+ Math::Vector position;
+ //! Direction in world space (for directional & spot lights)
+ Math::Vector direction;
+ //! Constant attenuation factor
+ float attenuation0;
+ //! Linear attenuation factor
+ float attenuation1;
+ //! Quadratic attenuation factor
+ float attenuation2;
+ //! Angle of spotlight cone (0-90 degrees)
+ float spotAngle;
+ //! Intensity of spotlight (0 = uniform; 128 = most intense)
+ float spotIntensity;
+
+ //! Constructor; calls LoadDefault()
+ Light()
+ {
+ LoadDefault();
+ }
+
+ //! Loads default values
+ void LoadDefault()
+ {
+ type = LIGHT_POINT;
+ ambient = Gfx::Color(0.4f, 0.4f, 0.4f);
+ diffuse = Gfx::Color(0.8f, 0.8f, 0.8f);
+ specular = Gfx::Color(1.0f, 1.0f, 1.0f);
+ position = Math::Vector(0.0f, 0.0f, 0.0f);
+ direction = Math::Vector(0.0f, 0.0f, 1.0f);
+ attenuation0 = 1.0f;
+ attenuation1 = attenuation2 = 0.0f;
+ spotAngle = 90.0f;
+ spotIntensity = 0.0f;
+ }
+};
+
+}; // namespace Gfx
diff --git a/src/graphics/common/material.h b/src/graphics/core/material.h
index c828d90..31b42f3 100644
--- a/src/graphics/common/material.h
+++ b/src/graphics/core/material.h
@@ -19,7 +19,7 @@
#pragma once
-#include "graphics/common/color.h"
+#include "graphics/core/color.h"
namespace Gfx {
diff --git a/src/graphics/common/texture.h b/src/graphics/core/texture.h
index 787c2bf..787c2bf 100644
--- a/src/graphics/common/texture.h
+++ b/src/graphics/core/texture.h
diff --git a/src/graphics/common/vertex.h b/src/graphics/core/vertex.h
index 0a74587..b7fab1c 100644
--- a/src/graphics/common/vertex.h
+++ b/src/graphics/core/vertex.h
@@ -19,7 +19,7 @@
#pragma once
-#include "graphics/common/color.h"
+#include "graphics/core/color.h"
#include "math/vector.h"
#include "math/point.h"
diff --git a/src/graphics/engine/README.txt b/src/graphics/engine/README.txt
new file mode 100644
index 0000000..308b601
--- /dev/null
+++ b/src/graphics/engine/README.txt
@@ -0,0 +1,8 @@
+src/graphics/engine
+
+Graphics engine
+
+CEngine class and various other classes implementing the main features
+of graphics engine from model loading to decorative particles
+
+Graphics operations are done on abstract interface from src/graphics/core
diff --git a/src/graphics/common/camera.cpp b/src/graphics/engine/camera.cpp
index 9990d01..04bf868 100644
--- a/src/graphics/common/camera.cpp
+++ b/src/graphics/engine/camera.cpp
@@ -17,7 +17,7 @@
// camera.cpp
-#include "graphics/common/camera.h"
+#include "graphics/engine/camera.h"
// TODO implementation
diff --git a/src/graphics/common/camera.h b/src/graphics/engine/camera.h
index 76077bf..76077bf 100644
--- a/src/graphics/common/camera.h
+++ b/src/graphics/engine/camera.h
diff --git a/src/graphics/common/cloud.cpp b/src/graphics/engine/cloud.cpp
index 707f641..d0e5ed8 100644
--- a/src/graphics/common/cloud.cpp
+++ b/src/graphics/engine/cloud.cpp
@@ -17,7 +17,7 @@
// cloud.cpp
-#include "graphics/common/cloud.h"
+#include "graphics/engine/cloud.h"
// TODO implementation
diff --git a/src/graphics/common/cloud.h b/src/graphics/engine/cloud.h
index 19b689f..d2d29d7 100644
--- a/src/graphics/common/cloud.h
+++ b/src/graphics/engine/cloud.h
@@ -20,7 +20,7 @@
#pragma once
#include "common/event.h"
-#include "graphics/common/color.h"
+#include "graphics/core/color.h"
#include "math/point.h"
#include "math/vector.h"
diff --git a/src/graphics/common/engine.cpp b/src/graphics/engine/engine.cpp
index e6dcfc7..0914f9e 100644
--- a/src/graphics/common/engine.cpp
+++ b/src/graphics/engine/engine.cpp
@@ -17,14 +17,14 @@
// engine.cpp
-#include "graphics/common/engine.h"
+#include "graphics/engine/engine.h"
#include "app/app.h"
#include "common/iman.h"
#include "common/image.h"
#include "common/key.h"
#include "common/logger.h"
-#include "graphics/common/device.h"
+#include "graphics/core/device.h"
#include "math/geometry.h"
// Initial size of various vectors
diff --git a/src/graphics/common/engine.h b/src/graphics/engine/engine.h
index 9b6cc1f..1348cdd 100644
--- a/src/graphics/common/engine.h
+++ b/src/graphics/engine/engine.h
@@ -21,10 +21,10 @@
#include "common/event.h"
-#include "graphics/common/color.h"
-#include "graphics/common/material.h"
-#include "graphics/common/texture.h"
-#include "graphics/common/vertex.h"
+#include "graphics/core/color.h"
+#include "graphics/core/material.h"
+#include "graphics/core/texture.h"
+#include "graphics/core/vertex.h"
#include "math/intpoint.h"
#include "math/matrix.h"
#include "math/point.h"
diff --git a/src/graphics/common/light.cpp b/src/graphics/engine/lightman.cpp
index 3ca890c..9e15b5a 100644
--- a/src/graphics/common/light.cpp
+++ b/src/graphics/engine/lightman.cpp
@@ -17,10 +17,10 @@
// light.cpp
-#include "graphics/common/light.h"
+#include "graphics/engine/lightman.h"
#include "common/iman.h"
-#include "graphics/common/device.h"
+#include "graphics/core/device.h"
#include "math/geometry.h"
#include <cmath>
diff --git a/src/graphics/common/light.h b/src/graphics/engine/lightman.h
index 93e8c1b..8272125 100644
--- a/src/graphics/common/light.h
+++ b/src/graphics/engine/lightman.h
@@ -15,81 +15,20 @@
// * You should have received a copy of the GNU General Public License
// * along with this program. If not, see http://www.gnu.org/licenses/.
-// light.h
+// lightman.h
#pragma once
-#include "graphics/common/engine.h"
-#include "graphics/common/color.h"
+#include "graphics/core/color.h"
+#include "graphics/core/light.h"
+#include "graphics/engine/engine.h"
#include "math/vector.h"
namespace Gfx {
/**
- \enum LightType
- \brief Type of light in 3D scene */
-enum LightType
-{
- LIGHT_POINT,
- LIGHT_SPOT,
- LIGHT_DIRECTIONAL
-};
-
-/**
- \struct Light
- \brief Properties of light in 3D scene
-
- This structure was created as analog to DirectX's D3DLIGHT. */
-struct Light
-{
- //! Type of light source
- Gfx::LightType type;
- //! Color of ambient light
- Gfx::Color ambient;
- //! Color of diffuse light
- Gfx::Color diffuse;
- //! Color of specular light
- Gfx::Color specular;
- //! Position in world space (for point & spot lights)
- Math::Vector position;
- //! Direction in world space (for directional & spot lights)
- Math::Vector direction;
- //! Constant attenuation factor
- float attenuation0;
- //! Linear attenuation factor
- float attenuation1;
- //! Quadratic attenuation factor
- float attenuation2;
- //! Angle of spotlight cone (0-90 degrees)
- float spotAngle;
- //! Intensity of spotlight (0 = uniform; 128 = most intense)
- float spotIntensity;
-
- //! Constructor; calls LoadDefault()
- Light()
- {
- LoadDefault();
- }
-
- //! Loads default values
- void LoadDefault()
- {
- type = LIGHT_POINT;
- ambient = Gfx::Color(0.4f, 0.4f, 0.4f);
- diffuse = Gfx::Color(0.8f, 0.8f, 0.8f);
- specular = Gfx::Color(1.0f, 1.0f, 1.0f);
- position = Math::Vector(0.0f, 0.0f, 0.0f);
- direction = Math::Vector(0.0f, 0.0f, 1.0f);
- attenuation0 = 1.0f;
- attenuation1 = attenuation2 = 0.0f;
- spotAngle = 90.0f;
- spotIntensity = 0.0f;
- }
-};
-
-/**
\struct LightProgression
\brief Describes the progression of light parameters change */
struct LightProgression
diff --git a/src/graphics/common/lightning.cpp b/src/graphics/engine/lightning.cpp
index 076fcb4..4db5511 100644
--- a/src/graphics/common/lightning.cpp
+++ b/src/graphics/engine/lightning.cpp
@@ -17,7 +17,7 @@
// lightning.cpp (aka blitz.cpp)
-#include "graphics/common/lightning.h"
+#include "graphics/engine/lightning.h"
// TODO implementation
diff --git a/src/graphics/common/lightning.h b/src/graphics/engine/lightning.h
index 957344c..957344c 100644
--- a/src/graphics/common/lightning.h
+++ b/src/graphics/engine/lightning.h
diff --git a/src/graphics/common/modelfile.cpp b/src/graphics/engine/modelfile.cpp
index 22801e8..537add4 100644
--- a/src/graphics/common/modelfile.cpp
+++ b/src/graphics/engine/modelfile.cpp
@@ -17,7 +17,7 @@
// modelfile.cpp (aka modfile.cpp)
-#include "graphics/common/modelfile.h"
+#include "graphics/engine/modelfile.h"
#include "common/iman.h"
#include "common/ioutils.h"
diff --git a/src/graphics/common/modelfile.h b/src/graphics/engine/modelfile.h
index f8cb022..6a30487 100644
--- a/src/graphics/common/modelfile.h
+++ b/src/graphics/engine/modelfile.h
@@ -17,9 +17,9 @@
// modelfile.h (aka modfile.h)
-#include "graphics/common/engine.h"
-#include "graphics/common/vertex.h"
-#include "graphics/common/material.h"
+#include "graphics/engine/engine.h"
+#include "graphics/core/vertex.h"
+#include "graphics/core/material.h"
#include "math/vector.h"
#include <string>
diff --git a/src/graphics/common/particle.cpp b/src/graphics/engine/particle.cpp
index 322c2d0..84e2f9d 100644
--- a/src/graphics/common/particle.cpp
+++ b/src/graphics/engine/particle.cpp
@@ -17,7 +17,7 @@
// particle.cpp (aka particule.cpp)
-#include "graphics/common/particle.h"
+#include "graphics/engine/particle.h"
// TODO implementation
diff --git a/src/graphics/common/particle.h b/src/graphics/engine/particle.h
index bd9741f..bd9741f 100644
--- a/src/graphics/common/particle.h
+++ b/src/graphics/engine/particle.h
diff --git a/src/graphics/common/planet.cpp b/src/graphics/engine/planet.cpp
index 4fa17a1..4f1f614 100644
--- a/src/graphics/common/planet.cpp
+++ b/src/graphics/engine/planet.cpp
@@ -17,7 +17,7 @@
// planet.cpp
-#include "graphics/common/planet.h"
+#include "graphics/engine/planet.h"
// TODO implementation
diff --git a/src/graphics/common/planet.h b/src/graphics/engine/planet.h
index 264d05c..264d05c 100644
--- a/src/graphics/common/planet.h
+++ b/src/graphics/engine/planet.h
diff --git a/src/graphics/common/pyro.cpp b/src/graphics/engine/pyro.cpp
index 6b5b1af..e699db2 100644
--- a/src/graphics/common/pyro.cpp
+++ b/src/graphics/engine/pyro.cpp
@@ -17,7 +17,7 @@
// pyro.cpp
-#include "graphics/common/pyro.h"
+#include "graphics/engine/pyro.h"
// TODO implementation
diff --git a/src/graphics/common/pyro.h b/src/graphics/engine/pyro.h
index fda74b3..d663ca5 100644
--- a/src/graphics/common/pyro.h
+++ b/src/graphics/engine/pyro.h
@@ -20,7 +20,7 @@
#pragma once
#include "common/misc.h"
-#include "graphics/common/engine.h"
+#include "graphics/engine/engine.h"
//#include "object/object.h"
// TEMPORARILY!
enum ObjectType {};
diff --git a/src/graphics/common/terrain.cpp b/src/graphics/engine/terrain.cpp
index 9b61dfc..c489321 100644
--- a/src/graphics/common/terrain.cpp
+++ b/src/graphics/engine/terrain.cpp
@@ -17,7 +17,7 @@
// terrain.cpp
-#include "graphics/common/terrain.h"
+#include "graphics/engine/terrain.h"
// TODO implementation
diff --git a/src/graphics/common/terrain.h b/src/graphics/engine/terrain.h
index fd9a1a6..8d8b165 100644
--- a/src/graphics/common/terrain.h
+++ b/src/graphics/engine/terrain.h
@@ -19,7 +19,7 @@
#pragma once
-#include "graphics/common/engine.h"
+#include "graphics/engine/engine.h"
class CInstanceManager;
diff --git a/src/graphics/common/test/CMakeLists.txt b/src/graphics/engine/test/CMakeLists.txt
index bd83773..bd83773 100644
--- a/src/graphics/common/test/CMakeLists.txt
+++ b/src/graphics/engine/test/CMakeLists.txt
diff --git a/src/graphics/common/test/modelfile_test.cpp b/src/graphics/engine/test/modelfile_test.cpp
index cc44f98..f7ed87f 100644
--- a/src/graphics/common/test/modelfile_test.cpp
+++ b/src/graphics/engine/test/modelfile_test.cpp
@@ -1,4 +1,4 @@
-#include "graphics/common/modelfile.h"
+#include "graphics/engine/modelfile.h"
#include "common/iman.h"
#include <iostream>
diff --git a/src/graphics/common/text.cpp b/src/graphics/engine/text.cpp
index 0c5eb66..2a9543c 100644
--- a/src/graphics/common/text.cpp
+++ b/src/graphics/engine/text.cpp
@@ -17,7 +17,7 @@
// text.cpp
-#include "graphics/common/text.h"
+#include "graphics/engine/text.h"
// TODO implementation
diff --git a/src/graphics/common/text.h b/src/graphics/engine/text.h
index f96dc61..c2de220 100644
--- a/src/graphics/common/text.h
+++ b/src/graphics/engine/text.h
@@ -19,8 +19,8 @@
#pragma once
-#include "graphics/common/engine.h"
-#include "graphics/common/device.h"
+#include "graphics/engine/engine.h"
+#include "graphics/core/device.h"
#include "math/point.h"
diff --git a/src/graphics/common/water.cpp b/src/graphics/engine/water.cpp
index 5172b9f..a157e82 100644
--- a/src/graphics/common/water.cpp
+++ b/src/graphics/engine/water.cpp
@@ -17,7 +17,7 @@
// water.cpp
-#include "graphics/common/water.h"
+#include "graphics/engine/water.h"
// TODO implementation
diff --git a/src/graphics/common/water.h b/src/graphics/engine/water.h
index f5224a4..67be9dc 100644
--- a/src/graphics/common/water.h
+++ b/src/graphics/engine/water.h
@@ -19,8 +19,8 @@
#pragma once
-#include "graphics/common/engine.h"
-#include "graphics/common/particle.h"
+#include "graphics/engine/engine.h"
+#include "graphics/engine/particle.h"
#include "common/event.h"
diff --git a/src/graphics/opengl/README.txt b/src/graphics/opengl/README.txt
index 11aba8d..0aba0ed 100644
--- a/src/graphics/opengl/README.txt
+++ b/src/graphics/opengl/README.txt
@@ -2,5 +2,5 @@ src/graphics/opengl
OpenGL engine implementation
-Contains the concreate implementation using OpenGL of functions
-of grahpics engine in graphics/common.
+Contains the concrete implementation using OpenGL of abstract CDevice class
+from src/graphics/core
diff --git a/src/graphics/opengl/gldevice.h b/src/graphics/opengl/gldevice.h
index b779123..313ea02 100644
--- a/src/graphics/opengl/gldevice.h
+++ b/src/graphics/opengl/gldevice.h
@@ -19,7 +19,7 @@
#pragma once
-#include "graphics/common/device.h"
+#include "graphics/core/device.h"
#include <string>
#include <vector>
diff --git a/src/graphics/opengl/test/CMakeLists.txt b/src/graphics/opengl/test/CMakeLists.txt
index 793e858..8ed7364 100644
--- a/src/graphics/opengl/test/CMakeLists.txt
+++ b/src/graphics/opengl/test/CMakeLists.txt
@@ -37,7 +37,7 @@ texture_test.cpp
set(MODEL_SOURCES
../gldevice.cpp
-../../common/modelfile.cpp
+../../engine/modelfile.cpp
../../../common/logger.cpp
../../../common/image.cpp
../../../common/iman.cpp
@@ -84,4 +84,4 @@ add_executable(transform_test ${TRANSFORM_SOURCES})
target_link_libraries(transform_test ${LIBS})
add_executable(light_test ${LIGHT_SOURCES})
-target_link_libraries(light_test ${LIBS}) \ No newline at end of file
+target_link_libraries(light_test ${LIBS})
diff --git a/src/graphics/opengl/test/model_test.cpp b/src/graphics/opengl/test/model_test.cpp
index 3e3d100..3e8efe6 100644
--- a/src/graphics/opengl/test/model_test.cpp
+++ b/src/graphics/opengl/test/model_test.cpp
@@ -2,7 +2,7 @@
#include "common/logger.h"
#include "common/image.h"
#include "common/iman.h"
-#include "graphics/common/modelfile.h"
+#include "graphics/engine/modelfile.h"
#include "graphics/opengl/gldevice.h"
#include "math/geometry.h"