summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-26 23:49:57 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-26 23:49:57 +0200
commit67290af2d2dc5d9f702b2d63c72bb980e2d85e40 (patch)
tree409404a3c20ef23ac0df3626fb2cbfcc7e885fb4 /CMakeLists.txt
parent77bd13f49fb974cb50918b18d166ab61240c0d34 (diff)
parent7319c642c6760b2ec828fb9de57b90ae3a89502e (diff)
downloadcolobot-67290af2d2dc5d9f702b2d63c72bb980e2d85e40.tar.gz
colobot-67290af2d2dc5d9f702b2d63c72bb980e2d85e40.tar.bz2
colobot-67290af2d2dc5d9f702b2d63c72bb980e2d85e40.zip
Merge with branch dev-opengl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae0231d..2d24e0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,10 +12,9 @@ find_package(SDL_image REQUIRED)
# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
-# Currently compiles only with -fpermissive
-
-set(CMAKE_CXX_FLAGS_RELEASE "-fpermissive -O2")
-set(CMAKE_CXX_FLAGS_DEBUG "-fpermissive -w -g -O0")
+# Global compile flags
+set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0")
# Subdirectory with sources
add_subdirectory(src bin)