summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-16 21:29:13 +0100
committerDidier Raboud <odyx@debian.org>2012-12-16 21:53:48 +0100
commitc190c3efaec57dcb550a57a56538010ff5e2b532 (patch)
tree181b0059363cd9e72af437468c40b7c1b7d7038f /CMakeLists.txt
parent0b78ebd0f79fa8dbdb69f748551b83cf3f1b947d (diff)
downloadcolobot-c190c3efaec57dcb550a57a56538010ff5e2b532.tar.gz
colobot-c190c3efaec57dcb550a57a56538010ff5e2b532.tar.bz2
colobot-c190c3efaec57dcb550a57a56538010ff5e2b532.zip
Set a default datadir, in sync with the data installation path.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d072fd0..5238c1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -162,5 +162,6 @@ endif()
# Subdirectory with sources
add_subdirectory(src bin)
-# TODO: provide data files as git submodule and setup correct data path
-install_files(/share/games/colobot ../data)
+# TODO: provide data files as git submodule
+set(COLOBOT_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/games/colobot CACHE PATH "Colobot shared data directory")
+install(DIRECTORY ../data DESTINATION ${COLOBOT_DATA_DIR})