summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-19 14:23:33 +0100
committerDidier Raboud <odyx@debian.org>2012-12-19 14:23:33 +0100
commit528a6a5702fc7f506f0b76b11b93d9a52a905e63 (patch)
treedc887b67ec3579e6493b7b70671ac26679844522 /debian
parent57136646fb412cb845369701c4496057f78d4fb1 (diff)
downloadcolobot-528a6a5702fc7f506f0b76b11b93d9a52a905e63.tar.gz
colobot-528a6a5702fc7f506f0b76b11b93d9a52a905e63.tar.bz2
colobot-528a6a5702fc7f506f0b76b11b93d9a52a905e63.zip
Add a debugging package
Diffstat (limited to 'debian')
-rw-r--r--debian/control14
-rwxr-xr-xdebian/rules5
2 files changed, 18 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 1269767..026ee06 100644
--- a/debian/control
+++ b/debian/control
@@ -47,6 +47,20 @@ Description: educational programming strategy game - data
.
This package contains the architecture-independent game data.
+Package: colobot-dbg
+Architecture: any
+Section: debug
+Depends: ${misc:Depends}, ${shlibs:Depends},
+ colobot (= ${binary:Version})
+Description: educational programming strategy game - debug symbols
+ Colobot (Colonize with Bots) is an educational game aiming to teach
+ programming through entertainment. You are playing as an astronaut on a
+ journey with robot helpers to find a planet for colonization. It features 3D
+ real-time graphics and a C++ and Java-like, object-oriented language, CBOT,
+ which can be used to program the robots available in the game.
+ .
+ This package contains the debugging symbols.
+
Package: colobot-dev-doc
Architecture: all
Section: doc
diff --git a/debian/rules b/debian/rules
index ff45b44..cfc9147 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,10 @@
#!/usr/bin/make -f
%:
- dh $@ --buildsystem=cmake --parallel
+ dh $@ \
+ --buildsystem=cmake \
+ --parallel \
+ --dbg-package=colobot-dbg
override_dh_auto_build:
dh_auto_build -a