summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2013-12-17 13:49:01 +0100
committerDidier Raboud <odyx@debian.org>2013-12-17 13:49:01 +0100
commita59d1606c3592fad39194c0bc6b49e555acf9f6f (patch)
tree3eb225feb5d3e1775af744d81931a9c7be4a0ed1 /debian
parenta5c441287542466e4ae98558fc323dab2fcdda78 (diff)
downloadcolobot-a59d1606c3592fad39194c0bc6b49e555acf9f6f.tar.gz
colobot-a59d1606c3592fad39194c0bc6b49e555acf9f6f.tar.bz2
colobot-a59d1606c3592fad39194c0bc6b49e555acf9f6f.zip
Add menu file and xpm icon
Therefore add imagemagick to Build-Depends to convert the icon from the 32x32 png Closes: #731838
Diffstat (limited to 'debian')
-rw-r--r--debian/colobot.install1
-rw-r--r--debian/colobot.menu6
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules6
4 files changed, 15 insertions, 1 deletions
diff --git a/debian/colobot.install b/debian/colobot.install
index 6d594f1..ecd08f8 100644
--- a/debian/colobot.install
+++ b/debian/colobot.install
@@ -4,6 +4,7 @@ usr/share/applications/colobot.desktop
usr/share/icons/hicolor/scalable/apps/colobot.svg
usr/share/icons/hicolor/48x48/apps/colobot.png
usr/share/icons/hicolor/32x32/apps/colobot.png
+debian/colobot.xpm usr/share/pixmaps/
usr/share/icons/hicolor/16x16/apps/colobot.png
usr/share/man/man6/colobot.6
usr/share/man/*/man6/colobot.6
diff --git a/debian/colobot.menu b/debian/colobot.menu
new file mode 100644
index 0000000..6b8e812
--- /dev/null
+++ b/debian/colobot.menu
@@ -0,0 +1,6 @@
+?package(colobot):needs="X11" \
+ section="Games/Adventure" \
+ title="Colobot" \
+ longtitle="Colobot - Colonize with bots - Game to learn programming" \
+ icon="/usr/share/pixmaps/colobot.xpm" \
+ command="/usr/games/colobot"
diff --git a/debian/control b/debian/control
index 4102536..064d3f7 100644
--- a/debian/control
+++ b/debian/control
@@ -22,7 +22,8 @@ Build-Depends:
po4a,
perl,
google-mock,
- libgtest-dev
+ libgtest-dev,
+ imagemagick
Build-Depends-Indep: doxygen, graphviz
Vcs-Git: git://anonscm.debian.org/collab-maint/colobot.git -b debian
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=collab-maint/colobot.git
diff --git a/debian/rules b/debian/rules
index 171cbb8..67410d6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,3 +14,9 @@ override_dh_auto_configure:
override_dh_auto_build:
dh_auto_build -a
dh_auto_build -i -- doc
+ # obj-* is the default builddirectory in debhelper
+ convert obj-$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)/desktop/32/colobot.png debian/colobot.xpm
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f debian/colobot.xpm