summaryrefslogtreecommitdiffstats
path: root/lib/gtest/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-12-14 21:42:43 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2012-12-14 21:42:43 +0100
commita4cf777fb8cb939db10998853fc9e40deb64aa8d (patch)
treeeddafe06250b4f510ed1d33f47a1a3ab5d833285 /lib/gtest/CMakeLists.txt
parent3f79167323e099ebf7ede9460d454958926f55a1 (diff)
downloadcolobot-a4cf777fb8cb939db10998853fc9e40deb64aa8d.tar.gz
colobot-a4cf777fb8cb939db10998853fc9e40deb64aa8d.tar.bz2
colobot-a4cf777fb8cb939db10998853fc9e40deb64aa8d.zip
Reverted lib/, fixed gtest path in CMakeLists.txt
Some gtest system packages use name gtest-all.cc. lib/ directory should be left in repository.
Diffstat (limited to 'lib/gtest/CMakeLists.txt')
-rw-r--r--lib/gtest/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/gtest/CMakeLists.txt b/lib/gtest/CMakeLists.txt
new file mode 100644
index 0000000..1279f7d
--- /dev/null
+++ b/lib/gtest/CMakeLists.txt
@@ -0,0 +1,9 @@
+cmake_minimum_required(VERSION 2.8)
+
+include_directories(. include)
+
+# pthread is not necessary
+add_definitions(-DGTEST_HAS_PTHREAD=0)
+
+# gtest-all.cc includes all other sources
+add_library(gtest STATIC src/gtest-all.cc)