summaryrefslogtreecommitdiffstats
path: root/src/CBot/CMakeLists.txt
diff options
context:
space:
mode:
authorZaba999 <qrwfw5rp>2012-09-29 23:53:57 +0200
committerZaba999 <qrwfw5rp>2012-09-29 23:53:57 +0200
commit95e1d101c82e43396fd93abfaa522e3651613c4c (patch)
tree9d72f27e84a25c7a744b31eb7612698506ac5b68 /src/CBot/CMakeLists.txt
parentaa9df8b1f0fbbad4c7be0214a19a90b8495a2067 (diff)
parentc8f39a4c96ab63f9e3edc96845e1b70c89b95d2b (diff)
downloadcolobot-95e1d101c82e43396fd93abfaa522e3651613c4c.tar.gz
colobot-95e1d101c82e43396fd93abfaa522e3651613c4c.tar.bz2
colobot-95e1d101c82e43396fd93abfaa522e3651613c4c.zip
Merge branch 'dev' of https://github.com/colobot/colobot into dev
Diffstat (limited to 'src/CBot/CMakeLists.txt')
-rw-r--r--src/CBot/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index 409ef3b..9f5b987 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -12,4 +12,8 @@ CBotVar.cpp
CBotWhile.cpp
)
-add_library(CBot SHARED ${SOURCES})
+if(${CBOT_STATIC})
+ add_library(CBot STATIC ${SOURCES})
+else()
+ add_library(CBot SHARED ${SOURCES})
+endif()