summaryrefslogtreecommitdiffstats
path: root/src/CBot/tests/CBot_console/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Zieliński <michal@zielinscy.org.pl>2012-12-27 12:40:58 +0100
committerMichał Zieliński <michal@zielinscy.org.pl>2012-12-27 12:40:58 +0100
commitfb13c0f219282ef888562fb0fcbbeefd915307d4 (patch)
tree52816490c878fc5f57a97e3c2357d934cb70e294 /src/CBot/tests/CBot_console/CMakeLists.txt
parent4e2982d4ddbd4c16793e0adaa96f5bfd6bd9148c (diff)
parentc2ebd5551ff2569f56e3321efd2d9bedaf079955 (diff)
downloadcolobot-fb13c0f219282ef888562fb0fcbbeefd915307d4.tar.gz
colobot-fb13c0f219282ef888562fb0fcbbeefd915307d4.tar.bz2
colobot-fb13c0f219282ef888562fb0fcbbeefd915307d4.zip
Merge branch 'dev-desktop-file' of git://github.com/OdyX/colobot
Diffstat (limited to 'src/CBot/tests/CBot_console/CMakeLists.txt')
-rw-r--r--src/CBot/tests/CBot_console/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/CBot/tests/CBot_console/CMakeLists.txt b/src/CBot/tests/CBot_console/CMakeLists.txt
index 7d9f034..9f0f244 100644
--- a/src/CBot/tests/CBot_console/CMakeLists.txt
+++ b/src/CBot/tests/CBot_console/CMakeLists.txt
@@ -3,11 +3,14 @@ cmake_minimum_required(VERSION 2.8)
project(CBot_console C CXX)
# Build with debugging symbols
-set(CMAKE_BUILD_TYPE debug)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
# Global compile flags
-set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -Wold-style-cast -std=gnu++0x")
-set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wold-style-cast -std=gnu++0x")
+set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0")
# Include cmake directory
SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${colobot_SOURCE_DIR}/cmake")