summaryrefslogtreecommitdiffstats
path: root/src/CBot
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-03-22 18:19:53 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2013-03-22 19:17:08 +0100
commit4a30800cf16d403a7c25d78388e2822aa396ac86 (patch)
tree772753228bab7b0b4ba47e89580ed86de0ca098f /src/CBot
parent1406464f0ce0b804298e2ee034bdd8bc7856e0dc (diff)
downloadcolobot-4a30800cf16d403a7c25d78388e2822aa396ac86.tar.gz
colobot-4a30800cf16d403a7c25d78388e2822aa396ac86.tar.bz2
colobot-4a30800cf16d403a7c25d78388e2822aa396ac86.zip
Fixes for compiling on MSYS
* fixed SDL_main() and putenv() issues * disabled desktop subdir for MSYS * disabled building CBot_console for now
Diffstat (limited to 'src/CBot')
-rw-r--r--src/CBot/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index daf08c6..fecd18e 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -16,5 +16,8 @@ if(${CBOT_STATIC})
add_library(CBot STATIC ${SOURCES})
else()
add_library(CBot SHARED ${SOURCES})
- install(TARGETS CBot LIBRARY DESTINATION ${COLOBOT_INSTALL_LIB_DIR})
+ install(TARGETS CBot LIBRARY
+ DESTINATION ${COLOBOT_INSTALL_LIB_DIR}
+ ARCHIVE DESTINATION ${COLOBOT_INSTALL_LIB_DIR}
+ RUNTIME DESTINATION ${COLOBOT_INSTALL_BIN_DIR})
endif()