summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-09-08 03:05:12 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-09-08 03:05:12 +0200
commit31c29ea482e3bb868e60a0de05d513511a942b97 (patch)
tree6101f1adeebbbf8c798cd51ec13e32549f14a44f /src/CMakeLists.txt
parent0b1e6949b0aaefd85f63c6a2d5f4d2b207e9b12d (diff)
downloadcolobot-31c29ea482e3bb868e60a0de05d513511a942b97.tar.gz
colobot-31c29ea482e3bb868e60a0de05d513511a942b97.tar.bz2
colobot-31c29ea482e3bb868e60a0de05d513511a942b97.zip
CModelFile fixes; test framework
- fixes in CModelFile IO - added Google Test framework for automatic testing - rewrote modelfile_test in the new framework
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ff271fd..0983a16 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,6 +4,9 @@ add_subdirectory(CBot)
# Tools directory is built separately
add_subdirectory(tools)
+# Tests
+add_subdirectory(graphics/engine/test)
+
# Configure options
option(DEBUG "Enable debug output" ON)