summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorErihel <erihel@gmail.com>2012-12-17 12:38:36 -0800
committerErihel <erihel@gmail.com>2012-12-17 12:38:36 -0800
commit7db96b45360fa7b5b5ff905b965fdce64b219da3 (patch)
tree0ccd65a52d1853db4517c9f6a52b836889cb0b17 /src/CMakeLists.txt
parent5a78b26f758ed0fa4b603ef086d21965e15010cd (diff)
parente062b74a3a0081e07527ffdbf1256d775a41bce1 (diff)
downloadcolobot-7db96b45360fa7b5b5ff905b965fdce64b219da3.tar.gz
colobot-7db96b45360fa7b5b5ff905b965fdce64b219da3.tar.bz2
colobot-7db96b45360fa7b5b5ff905b965fdce64b219da3.zip
Merge pull request #95 from OdyX/dev-move-cbot-to-private-lib
Install libCBot to a private directory
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4ffacd3..a7f3441 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -195,4 +195,5 @@ add_executable(colobot ${SOURCES})
target_link_libraries(colobot ${LIBS})
-install_targets(/games colobot)
+install(TARGETS colobot RUNTIME DESTINATION games/)
+set_target_properties(colobot PROPERTIES INSTALL_RPATH ${COLOBOT_LIB_DIR})