summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-07-27 18:09:50 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-07-27 18:09:50 +0200
commitab8e55a651f71921406bd216ca30f966db81c691 (patch)
tree78fc12d70ab9def2771f7176818d4231da0e2299 /src/CMakeLists.txt
parent4ddcd9f810fa588ccf90442f7b4e5ddf385e85f2 (diff)
parent6b846aa62924df0dea4af78c6333f0bd141bda78 (diff)
downloadcolobot-ab8e55a651f71921406bd216ca30f966db81c691.tar.gz
colobot-ab8e55a651f71921406bd216ca30f966db81c691.tar.bz2
colobot-ab8e55a651f71921406bd216ca30f966db81c691.zip
Merge branch 'dev' into dev-opengl
Pulled changes & resolved conflicts
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 76a10e9..da8463b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,5 @@
# CBot shared library is built separately
-# add_subdirectory(CBot) -- not yet WinAPI-independent
+add_subdirectory(CBot)
# Configure options
@@ -29,6 +29,7 @@ configure_file(common/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/common/config.h
# Source files
# Commented out files are still dependent on DirectX or WinAPI
+
set(SOURCES
app/app.cpp
app/main.cpp
@@ -155,8 +156,8 @@ ${SDL_LIBRARY}
${SDLIMAGE_LIBRARY}
${OPENGL_LIBRARY}
${PNG_LIBRARIES}
-#CBot -- not yet WinAPI-independent
${PLATFORM_LIBS}
+CBot
)
include_directories(. ${CMAKE_CURRENT_BINARY_DIR}