summaryrefslogtreecommitdiffstats
path: root/src/app/app.cpp
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-12-20 00:23:12 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2012-12-20 00:23:12 +0100
commitf77734e01c85aded92cf5fdc1e7038658e6aaf29 (patch)
tree27e84055413faaeeba630f305d92296df6d7eee2 /src/app/app.cpp
parente3db0b0c1970d3de8f86a4568dfcd1340f06b58b (diff)
downloadcolobot-f77734e01c85aded92cf5fdc1e7038658e6aaf29.tar.gz
colobot-f77734e01c85aded92cf5fdc1e7038658e6aaf29.tar.bz2
colobot-f77734e01c85aded92cf5fdc1e7038658e6aaf29.zip
Installation path fixes and CMakeLists refactoring
make && make install should now give a working installation.
Diffstat (limited to 'src/app/app.cpp')
-rw-r--r--src/app/app.cpp16
1 files changed, 6 insertions, 10 deletions
diff --git a/src/app/app.cpp b/src/app/app.cpp
index 04f8d2a..3073d77 100644
--- a/src/app/app.cpp
+++ b/src/app/app.cpp
@@ -30,12 +30,11 @@
#include "object/robotmain.h"
+#include <boost/filesystem.hpp>
#include <SDL/SDL.h>
#include <SDL/SDL_image.h>
-#include <fstream>
-
#include <stdlib.h>
#include <libintl.h>
#include <unistd.h>
@@ -131,7 +130,7 @@ CApplication::CApplication()
m_mouseButtonsState = 0;
m_trackedKeys = 0;
- m_dataPath = CBOT_DEFAULT_DATADIR;
+ m_dataPath = COLOBOT_DEFAULT_DATADIR;
m_language = LANGUAGE_ENV;
@@ -274,13 +273,10 @@ bool CApplication::Create()
{
GetLogger()->Info("Creating CApplication\n");
- // I know, a primitive way to check for dir, but works
- std::string readmePath = m_dataPath + "/README.txt";
- std::ifstream testReadme;
- testReadme.open(readmePath.c_str(), std::ios_base::in);
- if (!testReadme.good())
+ boost::filesystem::path dataPath(m_dataPath);
+ if (! (boost::filesystem::exists(dataPath) && boost::filesystem::is_directory(dataPath)) )
{
- GetLogger()->Error("Could not open test file in data dir: '%s'\n", readmePath.c_str());
+ GetLogger()->Error("Data directory '%s' doesn't exist or is not a directory\n", m_dataPath.c_str());
m_errorMessage = std::string("Could not read from data directory:\n") +
std::string("'") + m_dataPath + std::string("'\n") +
std::string("Please check your installation, or supply a valid data directory by -datadir option.");
@@ -322,7 +318,7 @@ bool CApplication::Create()
setlocale(LC_ALL, "");
GetLogger()->Debug("Set locale to '%s'\n", locale.c_str());
- bindtextdomain("colobot", CBOT_I18N_DIR);
+ bindtextdomain("colobot", COLOBOT_I18N_DIR);
bind_textdomain_codeset("colobot", "UTF-8");
textdomain("colobot");