summaryrefslogtreecommitdiffstats
path: root/src/common/misc.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
commit680af178196217bdd255d2bc851f240983144ac1 (patch)
tree77d713bace78c1becb1c96a2b36dd09e44d8d330 /src/common/misc.h
parentd6525b5661c364a46514aaa772c090ecb0bfd26c (diff)
downloadcolobot-680af178196217bdd255d2bc851f240983144ac1.tar.gz
colobot-680af178196217bdd255d2bc851f240983144ac1.tar.bz2
colobot-680af178196217bdd255d2bc851f240983144ac1.zip
Fixed include paths and CMakeLists.txt
Additionally, changed #ifndef to #pragma once everywhere
Diffstat (limited to 'src/common/misc.h')
-rw-r--r--src/common/misc.h10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/common/misc.h b/src/common/misc.h
index 9eaba53..fb1938e 100644
--- a/src/common/misc.h
+++ b/src/common/misc.h
@@ -16,14 +16,14 @@
// misc.h
-#ifndef _MISC_H_
-#define _MISC_H_
+#pragma once
+
#include <time.h>
-#include "metafile.h"
-#include "event.h"
+#include "common/metafile.h"
+#include "common/event.h"
extern CMetaFile g_metafile;
@@ -236,5 +236,3 @@ extern void UserDir(char* buffer, char* dir, char* def);
extern char RetLanguageLetter();
-
-#endif //_MISC_H_