summaryrefslogtreecommitdiffstats
path: root/src/common
diff options
context:
space:
mode:
authorZaba999 <qrwfw5rp>2012-10-11 23:10:07 +0200
committerZaba999 <qrwfw5rp>2012-10-11 23:10:07 +0200
commit7575ffd49b76aaf4b054c0ca8cb8369fb12c11c9 (patch)
tree10915bce6a98c2b0848421dbb79b36ce52bb045b /src/common
parent8a932fed3e5700af283017deab3cb1da11cb0dce (diff)
parentdfe21c5a9c2ebf3df0f445014588bcce0387d699 (diff)
downloadcolobot-7575ffd49b76aaf4b054c0ca8cb8369fb12c11c9.tar.gz
colobot-7575ffd49b76aaf4b054c0ca8cb8369fb12c11c9.tar.bz2
colobot-7575ffd49b76aaf4b054c0ca8cb8369fb12c11c9.zip
Merge branch 'dev' of https://github.com/colobot/colobot into dev
Diffstat (limited to 'src/common')
-rw-r--r--src/common/restext.cpp6
-rw-r--r--src/common/test/CMakeLists.txt6
2 files changed, 7 insertions, 5 deletions
diff --git a/src/common/restext.cpp b/src/common/restext.cpp
index 0f33f52..9a3d964 100644
--- a/src/common/restext.cpp
+++ b/src/common/restext.cpp
@@ -105,7 +105,7 @@ static void PutKeyName(char* dst, const char* src)
{
if ( SearchKey(src+s+5, key) )
{
- res = CRobotMain::GetInstancePointer()->GetInputBinding(key).key;
+ res = CRobotMain::GetInstancePointer()->GetInputBinding(key).primary;
if (res != KEY_INVALID)
{
if ( GetResource(RES_KEY, res, name) )
@@ -172,7 +172,9 @@ static const char* GetResourceBase(ResType type, int num)
case RES_KEY:
- if (num == VIRTUAL_KMOD_CTRL)
+ if (num == KEY_INVALID)
+ return "";
+ else if (num == VIRTUAL_KMOD_CTRL)
return "Ctrl";
else if (num == VIRTUAL_KMOD_SHIFT)
return "Shift";
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index 7936862..ccbb739 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -14,7 +14,7 @@ ${GTEST_DIR}/include
add_executable(image_test ../image.cpp image_test.cpp)
target_link_libraries(image_test ${SDL_LIBRARY} ${SDLIMAGE_LIBRARY} ${PNG_LIBRARIES})
-add_executable(profile_test ../profile.cpp ../logger.cpp profile_test.cpp)
-target_link_libraries(profile_test gtest ${Boost_LIBRARIES})
+#add_executable(profile_test ../profile.cpp ../logger.cpp profile_test.cpp)
+#target_link_libraries(profile_test gtest ${Boost_LIBRARIES})
-add_test(profile_test ./profile_test)
+#add_test(profile_test ./profile_test)