summaryrefslogtreecommitdiffstats
path: root/src/desktop
diff options
context:
space:
mode:
authorMichał Zieliński <michal@zielinscy.org.pl>2012-12-27 12:55:59 +0100
committerMichał Zieliński <michal@zielinscy.org.pl>2012-12-27 12:55:59 +0100
commitcf65681f8029c2c1e5f18cc3776bdb09c8bd1db0 (patch)
tree52816490c878fc5f57a97e3c2357d934cb70e294 /src/desktop
parent9f3acdcdde36ece74a848370776b2751d20f1c3d (diff)
downloadcolobot-cf65681f8029c2c1e5f18cc3776bdb09c8bd1db0.tar.gz
colobot-cf65681f8029c2c1e5f18cc3776bdb09c8bd1db0.tar.bz2
colobot-cf65681f8029c2c1e5f18cc3776bdb09c8bd1db0.zip
Revert "Merge branch 'dev-desktop-file-man' of https://github.com/OdyX/colobot"
This reverts commit 9f3acdcdde36ece74a848370776b2751d20f1c3d, reversing changes made to fb13c0f219282ef888562fb0fcbbeefd915307d4.
Diffstat (limited to 'src/desktop')
-rw-r--r--src/desktop/.gitignore1
-rw-r--r--src/desktop/CMakeLists.txt47
-rw-r--r--src/desktop/colobot.pod47
-rw-r--r--src/desktop/po/colobot-desktop.pot106
-rw-r--r--src/desktop/po/fr.po127
-rw-r--r--src/desktop/po4a.cfg1
6 files changed, 5 insertions, 324 deletions
diff --git a/src/desktop/.gitignore b/src/desktop/.gitignore
deleted file mode 100644
index bade6f3..0000000
--- a/src/desktop/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-lang/
diff --git a/src/desktop/CMakeLists.txt b/src/desktop/CMakeLists.txt
index 1e5058f..cc159a9 100644
--- a/src/desktop/CMakeLists.txt
+++ b/src/desktop/CMakeLists.txt
@@ -37,40 +37,6 @@ if(RSVG_CONVERT)
endforeach()
endif()
-# Create manpage from pod-formatted file
-find_program(POD2MAN pod2man)
-if(POD2MAN)
- set(COLOBOT_MANPAGE_SECTION 6)
-
- macro(podman)
- cmake_parse_arguments(PM "" "PODFILE;LOCALE;" "" ${ARGN})
- if(PM_LOCALE)
- # This copes with the fact that english has no "/LANG" in the paths and filenames.
- set(SLASHLOCALE /${PM_LOCALE})
- endif()
- file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}${SLASHLOCALE})
- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}${SLASHLOCALE}/colobot.${COLOBOT_MANPAGE_SECTION}
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${PM_PODFILE}
- COMMAND ${POD2MAN} ARGS --section=${COLOBOT_MANPAGE_SECTION}
- --center="Colobot" --stderr --utf8
- ${CMAKE_CURRENT_SOURCE_DIR}/${PM_PODFILE}
- ${CMAKE_CURRENT_BINARY_DIR}${SLASHLOCALE}/colobot.${COLOBOT_MANPAGE_SECTION}
- COMMENT "Create ${SLASHLOCALE}/colobot.${COLOBOT_MANPAGE_SECTION} manpage"
- )
- add_custom_target(man${PM_LOCALE} DEPENDS ${CMAKE_CURRENT_BINARY_DIR}${SLASHLOCALE}/colobot.${COLOBOT_MANPAGE_SECTION})
-
- install(
- FILES ${CMAKE_CURRENT_BINARY_DIR}${SLASHLOCALE}/colobot.${COLOBOT_MANPAGE_SECTION}
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man${SLASHLOCALE}/man${COLOBOT_MANPAGE_SECTION}/ )
-
- add_dependencies(man man${PM_LOCALE})
- endmacro()
-
- # Create the english manpage
- podman(PODFILE colobot.pod)
-
-endif()
-
# Translate translatable material
find_program(PO4A po4a)
@@ -80,17 +46,4 @@ if(PO4A)
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
add_dependencies(desktopfile desktop_po4a)
-
- if(POD2MAN)
- add_custom_target(man_po4a
- COMMAND ${PO4A} po4a.cfg
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- )
- add_dependencies(man man_po4a)
- file(GLOB LINGUAS_PO RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/po/ ${CMAKE_CURRENT_SOURCE_DIR}/po/*.po)
- string(REGEX REPLACE ".po$" "" LINGUAS ${LINGUAS_PO})
- foreach(LOCALE ${LINGUAS})
- podman(PODFILE lang/${LOCALE}/colobot.pod LOCALE ${LOCALE})
- endforeach()
- endif()
endif()
diff --git a/src/desktop/colobot.pod b/src/desktop/colobot.pod
deleted file mode 100644
index 2fc3a00..0000000
--- a/src/desktop/colobot.pod
+++ /dev/null
@@ -1,47 +0,0 @@
-=encoding utf8
-
-=head1 COLOBOT
-
-colobot - educational programming strategy game
-
-=head1 SYNOPSIS
-
-B<colobot> [B<-datadir> I<path>] [B<-debug>] [B<-loglevel> I<level>] [B<-language> I<lang>]
-
-=head1 DESCRIPTION
-
-Colobot (Colonize with Bots) is an educational game aiming to teach
-programming through entertainment. You are playing as an astronaut on a
-journey with robot helpers to find a planet for colonization. It features 3D
-real-time graphics and a C++ and Java-like, object-oriented language, CBOT,
-which can be used to program the robots available in the game.
-
-=head1 OPTIONS
-
-=over 8
-
-=item B<-help>
-
-Display a short help text
-
-=item B<-datadir> F</path/to/data/>
-
-Set custom data directory path
-
-=item B<-debug>
-
-Enable debug mode (more info printed in logs)
-
-=item B<-loglevel> I<level>
-
-Set log level. Possible choices are: trace, debug, info, warn, error, none.
-
-=item B<-language> I<lang>
-
-Set language. Note that you can also fill the B<LANG> environment variable.
-
-=back
-
-=head1 AUTHOR
-
-This manpage was written by Didier Raboud <S<odyx@debian.org>>.
diff --git a/src/desktop/po/colobot-desktop.pot b/src/desktop/po/colobot-desktop.pot
index 17e60c3..e74136a 100644
--- a/src/desktop/po/colobot-desktop.pot
+++ b/src/desktop/po/colobot-desktop.pot
@@ -7,13 +7,13 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2012-12-27 10:59+0100\n"
+"POT-Creation-Date: 2012-12-26 15:05+0100\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
"Language: \n"
"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Type: text/plain; charset=CHARSET\n"
"Content-Transfer-Encoding: 8bit\n"
#: colobot.ini:1
@@ -30,105 +30,3 @@ msgstr ""
#, no-wrap
msgid "Colonize with bots"
msgstr ""
-
-#. type: =head1
-#: colobot.pod:3
-msgid "COLOBOT"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:5
-msgid "colobot - educational programming strategy game"
-msgstr ""
-
-#. type: =head1
-#: colobot.pod:7
-msgid "SYNOPSIS"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:9
-msgid ""
-"B<colobot> [B<-datadir> I<path>] [B<-debug>] [B<-loglevel> I<level>] "
-"[B<-language> I<lang>]"
-msgstr ""
-
-#. type: =head1
-#: colobot.pod:11
-msgid "DESCRIPTION"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:13
-msgid ""
-"Colobot (Colonize with Bots) is an educational game aiming to teach "
-"programming through entertainment. You are playing as an astronaut on a "
-"journey with robot helpers to find a planet for colonization. It features 3D "
-"real-time graphics and a C++ and Java-like, object-oriented language, CBOT, "
-"which can be used to program the robots available in the game."
-msgstr ""
-
-#. type: =head1
-#: colobot.pod:19
-msgid "OPTIONS"
-msgstr ""
-
-#. type: =item
-#: colobot.pod:23
-msgid "B<-help>"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:25
-msgid "Display a short help text"
-msgstr ""
-
-#. type: =item
-#: colobot.pod:27
-msgid "B<-datadir> F</path/to/data/>"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:29
-msgid "Set custom data directory path"
-msgstr ""
-
-#. type: =item
-#: colobot.pod:31
-msgid "B<-debug>"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:33
-msgid "Enable debug mode (more info printed in logs)"
-msgstr ""
-
-#. type: =item
-#: colobot.pod:35
-msgid "B<-loglevel> I<level>"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:37
-msgid "Set log level. Possible choices are: trace, debug, info, warn, error, none."
-msgstr ""
-
-#. type: =item
-#: colobot.pod:39
-msgid "B<-language> I<lang>"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:41
-msgid "Set language. Note that you can also fill the B<LANG> environment variable."
-msgstr ""
-
-#. type: =head1
-#: colobot.pod:45
-msgid "AUTHOR"
-msgstr ""
-
-#. type: textblock
-#: colobot.pod:47
-msgid "This manpage was written by Didier Raboud <S<odyx@debian.org>>."
-msgstr ""
diff --git a/src/desktop/po/fr.po b/src/desktop/po/fr.po
index 4709d49..63dbb23 100644
--- a/src/desktop/po/fr.po
+++ b/src/desktop/po/fr.po
@@ -1,13 +1,13 @@
# French translations for PACKAGE package
# Copyright (C) 2012 Free Software Foundation, Inc.
# This file is distributed under the same license as the PACKAGE package.
+# Automatically generated, 2012.
#
-# Didier Raboud <odyx@debian.org>, 2012.
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2012-12-27 10:55+0100\n"
-"PO-Revision-Date: 2012-12-27 11:00+0100\n"
+"POT-Creation-Date: 2012-12-26 15:05+0100\n"
+"PO-Revision-Date: 2012-12-26 15:05+0100\n"
"Last-Translator: Didier Raboud <odyx@debian.org>\n"
"Language-Team: none\n"
"Language: fr\n"
@@ -30,124 +30,3 @@ msgstr "Apprentissage de la programmation par le jeu"
#, no-wrap
msgid "Colonize with bots"
msgstr "Colonise avec des roBots"
-
-#. type: =head1
-#: colobot.pod:3
-msgid "COLOBOT"
-msgstr "COLOBOT"
-
-#. type: textblock
-#: colobot.pod:5
-msgid "colobot - educational programming strategy game"
-msgstr "colobot - Jeu éducatif de stratégie et de programmation"
-
-#. type: =head1
-#: colobot.pod:7
-msgid "SYNOPSIS"
-msgstr "RÉSUMÉ"
-
-#. type: textblock
-#: colobot.pod:9
-msgid ""
-"B<colobot> [B<-datadir> I<path>] [B<-debug>] [B<-loglevel> I<level>] [B<-"
-"language> I<lang>]"
-msgstr ""
-"B<colobot> [B<-datadir> I<chemin>] [B<-debug>] [B<-loglevel> I<niveau>] [B<-"
-"language> I<code-de-langue>]"
-
-#. type: =head1
-#: colobot.pod:11
-msgid "DESCRIPTION"
-msgstr "DESCRIPTION"
-
-#. type: textblock
-#: colobot.pod:13
-msgid ""
-"Colobot (Colonize with Bots) is an educational game aiming to teach "
-"programming through entertainment. You are playing as an astronaut on a "
-"journey with robot helpers to find a planet for colonization. It features 3D "
-"real-time graphics and a C++ and Java-like, object-oriented language, CBOT, "
-"which can be used to program the robots available in the game."
-msgstr ""
-"Colobot (Colonise avec des roBots) est un jeu éducatif visant à "
-"l'enseignement de la programmation par le jeu. Vous jouez un astronaute en "
-"voyage avec des robots à la recherche d'une planète à coloniser. Son "
-"interface est en trois-dimensions et en temps réel; le language utilisé "
-"(CBOT) ressemble au C++ et à Java et peut être utilisé pour programmer les "
-"robots disponibles dans le jeu."
-
-#. type: =head1
-#: colobot.pod:19
-msgid "OPTIONS"
-msgstr "OPTIONS"
-
-#. type: =item
-#: colobot.pod:23
-msgid "B<-help>"
-msgstr "B<-help>"
-
-#. type: textblock
-#: colobot.pod:25
-msgid "Display a short help text"
-msgstr "Affiche un court texte d'aide"
-
-#. type: =item
-#: colobot.pod:27
-msgid "B<-datadir> F</path/to/data/>"
-msgstr "B<-datadir> F</chemin/vers/les/donnes/>"
-
-#. type: textblock
-#: colobot.pod:29
-msgid "Set custom data directory path"
-msgstr "Définit le chemin vers un répertoire de données spécifique"
-
-#. type: =item
-#: colobot.pod:31
-msgid "B<-debug>"
-msgstr "B<-debug>"
-
-#. type: textblock
-#: colobot.pod:33
-msgid "Enable debug mode (more info printed in logs)"
-msgstr ""
-"Active le mode de déboguage (plus d'informations sont affichées dans le "
-"journal)"
-
-#. type: =item
-#: colobot.pod:35
-msgid "B<-loglevel> I<level>"
-msgstr "B<-loglevel> I<niveau>"
-
-#. type: textblock
-#: colobot.pod:37
-msgid ""
-"Set log level. Possible choices are: trace, debug, info, warn, error, none."
-msgstr ""
-"Définit le niveau de journalisation parmi: trace, debug, info, warn, error, "
-"none."
-
-#. type: =item
-#: colobot.pod:39
-msgid "B<-language> I<lang>"
-msgstr "B<-language> I<langue>"
-
-#. type: textblock
-#: colobot.pod:41
-msgid ""
-"Set language. Note that you can also fill the B<LANG> environment variable."
-msgstr ""
-"Définit la langue. Il est aussi possible d'utiliser la variable "
-"d'environnement B<LANG>."
-
-#. type: =head1
-#: colobot.pod:45
-msgid "AUTHOR"
-msgstr "Auteur"
-
-#. type: textblock
-#: colobot.pod:47
-msgid "This manpage was written by Didier Raboud <S<odyx@debian.org>>."
-msgstr ""
-"Cette page de manuel a été écrite et traduite par Didier Raboud "
-"<S<odyx@debian.org>>."
-
diff --git a/src/desktop/po4a.cfg b/src/desktop/po4a.cfg
index c251959..eda2985 100644
--- a/src/desktop/po4a.cfg
+++ b/src/desktop/po4a.cfg
@@ -1,4 +1,3 @@
[po_directory] po/
[type:ini] colobot.ini $lang:lang/$lang/colobot.ini
-[type:pod] colobot.pod $lang:lang/$lang/colobot.pod