summaryrefslogtreecommitdiffstats
path: root/src/graphics/common/color.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
commit680af178196217bdd255d2bc851f240983144ac1 (patch)
tree77d713bace78c1becb1c96a2b36dd09e44d8d330 /src/graphics/common/color.h
parentd6525b5661c364a46514aaa772c090ecb0bfd26c (diff)
downloadcolobot-680af178196217bdd255d2bc851f240983144ac1.tar.gz
colobot-680af178196217bdd255d2bc851f240983144ac1.tar.bz2
colobot-680af178196217bdd255d2bc851f240983144ac1.zip
Fixed include paths and CMakeLists.txt
Additionally, changed #ifndef to #pragma once everywhere
Diffstat (limited to 'src/graphics/common/color.h')
-rw-r--r--src/graphics/common/color.h6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/graphics/common/color.h b/src/graphics/common/color.h
index 9d6114a..fff4b00 100644
--- a/src/graphics/common/color.h
+++ b/src/graphics/common/color.h
@@ -16,16 +16,18 @@
// color.h
+#pragma once
+
+
// TODO
struct Color
{
};
-#pragma once
-
D3DCOLOR RetColor(float intensity);
D3DCOLOR RetColor(D3DCOLORVALUE intensity);
D3DCOLORVALUE RetColor(D3DCOLOR intensity);
void RGB2HSV(D3DCOLORVALUE src, ColorHSV &dest);
void HSV2RGB(ColorHSV src, D3DCOLORVALUE &dest);
+