summaryrefslogtreecommitdiffstats
path: root/src/graphics/core/device.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-01-05 23:03:06 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2013-01-05 23:03:06 +0100
commit8818a8e5db86f140230d789427373e1771747f5d (patch)
treeae3d51735c50fa6c85008a6bf3c8b13caf9166d7 /src/graphics/core/device.h
parentd1942e1216768d41bc747a79287962a76a3aeb75 (diff)
downloadcolobot-8818a8e5db86f140230d789427373e1771747f5d.tar.gz
colobot-8818a8e5db86f140230d789427373e1771747f5d.tar.bz2
colobot-8818a8e5db86f140230d789427373e1771747f5d.zip
Corrected OpenGL extension detection
- corrected multitexture and VBO detection - GLEW is now a required library - minor CMakeLists refactoring
Diffstat (limited to 'src/graphics/core/device.h')
-rw-r--r--src/graphics/core/device.h5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/graphics/core/device.h b/src/graphics/core/device.h
index 618d21a..41d7796 100644
--- a/src/graphics/core/device.h
+++ b/src/graphics/core/device.h
@@ -104,8 +104,7 @@ enum RenderState
RENDER_STATE_DEPTH_TEST,
RENDER_STATE_DEPTH_WRITE,
RENDER_STATE_ALPHA_TEST,
- RENDER_STATE_CULLING,
- RENDER_STATE_DITHERING
+ RENDER_STATE_CULLING
};
/**
@@ -287,7 +286,7 @@ public:
virtual void DestroyAllTextures() = 0;
//! Returns the maximum number of multitexture stages
- virtual int GetMaxTextureCount() = 0;
+ virtual int GetMaxTextureStageCount() = 0;
//! Sets the texture at given texture stage
virtual void SetTexture(int index, const Texture &texture) = 0;
//! Sets the texture image by ID at given texture stage