summaryrefslogtreecommitdiffstats
path: root/src/graphics/engine/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-09-08 03:05:12 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-09-08 03:05:12 +0200
commit31c29ea482e3bb868e60a0de05d513511a942b97 (patch)
tree6101f1adeebbbf8c798cd51ec13e32549f14a44f /src/graphics/engine/test/CMakeLists.txt
parent0b1e6949b0aaefd85f63c6a2d5f4d2b207e9b12d (diff)
downloadcolobot-31c29ea482e3bb868e60a0de05d513511a942b97.tar.gz
colobot-31c29ea482e3bb868e60a0de05d513511a942b97.tar.bz2
colobot-31c29ea482e3bb868e60a0de05d513511a942b97.zip
CModelFile fixes; test framework
- fixes in CModelFile IO - added Google Test framework for automatic testing - rewrote modelfile_test in the new framework
Diffstat (limited to 'src/graphics/engine/test/CMakeLists.txt')
-rw-r--r--src/graphics/engine/test/CMakeLists.txt25
1 files changed, 22 insertions, 3 deletions
diff --git a/src/graphics/engine/test/CMakeLists.txt b/src/graphics/engine/test/CMakeLists.txt
index bd83773..4e3263b 100644
--- a/src/graphics/engine/test/CMakeLists.txt
+++ b/src/graphics/engine/test/CMakeLists.txt
@@ -1,7 +1,26 @@
cmake_minimum_required(VERSION 2.8)
set(CMAKE_BUILD_TYPE debug)
-set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
-include_directories(. ../../..)
-add_executable(modelfile_test modelfile_test.cpp ../modelfile.cpp ../../../common/logger.cpp ../../../common/stringutils.cpp ../../../common/iman.cpp)
+set(MODELFILE_TEST_SOURCES
+modelfile_test.cpp
+../modelfile.cpp
+../../../common/logger.cpp
+../../../common/stringutils.cpp
+../../../common/iman.cpp
+)
+
+add_definitions(-DMODELFILE_NO_ENGINE)
+
+include_directories(
+.
+../../..
+${GTEST_DIR}/include
+)
+
+add_executable(modelfile_test ${MODELFILE_TEST_SOURCES})
+
+target_link_libraries(modelfile_test gtest)
+
+add_test(modelfile_test modelfile_test)