summaryrefslogtreecommitdiffstats
path: root/src/graphics/opengl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Konopacki <konopacki.m@gmail.com>2012-08-13 21:23:20 +0200
committerMichał Konopacki <konopacki.m@gmail.com>2012-08-13 21:23:20 +0200
commit9ee1d2e172162be25b113595ad16779aa0a49a87 (patch)
tree5036de076ff1cf804bacfc866c2a8f04dc6c66f8 /src/graphics/opengl/test/CMakeLists.txt
parentdc3cadd309a1ac1eb4921de69fed6037881b0b91 (diff)
parenta2dd39960b5851f8e62adf59b11b36ba14626468 (diff)
downloadcolobot-9ee1d2e172162be25b113595ad16779aa0a49a87.tar.gz
colobot-9ee1d2e172162be25b113595ad16779aa0a49a87.tar.bz2
colobot-9ee1d2e172162be25b113595ad16779aa0a49a87.zip
Merge remote-tracking branch 'upstream/dev-graphics' into dev-ui
Diffstat (limited to 'src/graphics/opengl/test/CMakeLists.txt')
-rw-r--r--src/graphics/opengl/test/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/graphics/opengl/test/CMakeLists.txt b/src/graphics/opengl/test/CMakeLists.txt
index 8ed7364..be33ac6 100644
--- a/src/graphics/opengl/test/CMakeLists.txt
+++ b/src/graphics/opengl/test/CMakeLists.txt
@@ -6,7 +6,7 @@ find_package(SDL_image REQUIRED)
find_package(PNG REQUIRED)
set(CMAKE_BUILD_TYPE debug)
-set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0")
+set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -Wold-style-cast -std=gnu++0x")
set(ADD_LIBS "")
@@ -77,8 +77,9 @@ ${ADD_LIBS}
add_executable(texture_test ${TEXTURE_SOURCES})
target_link_libraries(texture_test ${LIBS})
-add_executable(model_test ${MODEL_SOURCES})
-target_link_libraries(model_test ${LIBS})
+# Temporarily disabling because of dependencies on CEngine et al.
+#add_executable(model_test ${MODEL_SOURCES})
+#target_link_libraries(model_test ${LIBS})
add_executable(transform_test ${TRANSFORM_SOURCES})
target_link_libraries(transform_test ${LIBS})