summaryrefslogtreecommitdiffstats
path: root/src/graphics
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-19 16:52:11 +0100
committerDidier Raboud <odyx@debian.org>2012-12-19 16:52:17 +0100
commit3c976c040b48caa9f3e75d12a6502e39193ce9a6 (patch)
tree84274fd4718d78613beb1b92e4cbb51e64e1fefc /src/graphics
parentfec2c1028a7d0f46f38c985c18d8cf778456f643 (diff)
downloadcolobot-3c976c040b48caa9f3e75d12a6502e39193ce9a6.tar.gz
colobot-3c976c040b48caa9f3e75d12a6502e39193ce9a6.tar.bz2
colobot-3c976c040b48caa9f3e75d12a6502e39193ce9a6.zip
Don't enforce CMake build type on users.
Only set CMAKE_BUILD_TYPE to Debug when no value is provided.
Diffstat (limited to 'src/graphics')
-rw-r--r--src/graphics/engine/test/CMakeLists.txt4
-rw-r--r--src/graphics/opengl/test/CMakeLists.txt4
2 files changed, 6 insertions, 2 deletions
diff --git a/src/graphics/engine/test/CMakeLists.txt b/src/graphics/engine/test/CMakeLists.txt
index 775abe5..b08e02d 100644
--- a/src/graphics/engine/test/CMakeLists.txt
+++ b/src/graphics/engine/test/CMakeLists.txt
@@ -1,6 +1,8 @@
cmake_minimum_required(VERSION 2.8)
-set(CMAKE_BUILD_TYPE debug)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
set(MODELFILE_TEST_SOURCES
diff --git a/src/graphics/opengl/test/CMakeLists.txt b/src/graphics/opengl/test/CMakeLists.txt
index be33ac6..3a0cc2a 100644
--- a/src/graphics/opengl/test/CMakeLists.txt
+++ b/src/graphics/opengl/test/CMakeLists.txt
@@ -5,7 +5,9 @@ find_package(SDL REQUIRED)
find_package(SDL_image REQUIRED)
find_package(PNG REQUIRED)
-set(CMAKE_BUILD_TYPE debug)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -Wold-style-cast -std=gnu++0x")
set(ADD_LIBS "")