summaryrefslogtreecommitdiffstats
path: root/src/object/motion/motiontoto.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
commit680af178196217bdd255d2bc851f240983144ac1 (patch)
tree77d713bace78c1becb1c96a2b36dd09e44d8d330 /src/object/motion/motiontoto.h
parentd6525b5661c364a46514aaa772c090ecb0bfd26c (diff)
downloadcolobot-680af178196217bdd255d2bc851f240983144ac1.tar.gz
colobot-680af178196217bdd255d2bc851f240983144ac1.tar.bz2
colobot-680af178196217bdd255d2bc851f240983144ac1.zip
Fixed include paths and CMakeLists.txt
Additionally, changed #ifndef to #pragma once everywhere
Diffstat (limited to 'src/object/motion/motiontoto.h')
-rw-r--r--src/object/motion/motiontoto.h11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/object/motion/motiontoto.h b/src/object/motion/motiontoto.h
index 22955bb..3549638 100644
--- a/src/object/motion/motiontoto.h
+++ b/src/object/motion/motiontoto.h
@@ -16,13 +16,12 @@
// motiontoto.h
-#ifndef _MOTIONTOTO_H_
-#define _MOTIONTOTO_H_
+#pragma once
-#include "struct.h"
-#include "object.h"
-#include "motion.h"
+#include "common/struct.h"
+#include "object/object.h"
+#include "object/motion/motion.h"
class CInstanceManager;
@@ -77,5 +76,3 @@ protected:
FPOINT m_mousePos;
};
-
-#endif //_MOTIONTOTO_H_