summaryrefslogtreecommitdiffstats
path: root/src/object/object.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
commit680af178196217bdd255d2bc851f240983144ac1 (patch)
tree77d713bace78c1becb1c96a2b36dd09e44d8d330 /src/object/object.h
parentd6525b5661c364a46514aaa772c090ecb0bfd26c (diff)
downloadcolobot-680af178196217bdd255d2bc851f240983144ac1.tar.gz
colobot-680af178196217bdd255d2bc851f240983144ac1.tar.bz2
colobot-680af178196217bdd255d2bc851f240983144ac1.zip
Fixed include paths and CMakeLists.txt
Additionally, changed #ifndef to #pragma once everywhere
Diffstat (limited to 'src/object/object.h')
-rw-r--r--src/object/object.h11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/object/object.h b/src/object/object.h
index af7a3e4..08f413b 100644
--- a/src/object/object.h
+++ b/src/object/object.h
@@ -16,13 +16,12 @@
// object.h
-#ifndef _OBJECT_H_
-#define _OBJECT_H_
+#pragma once
-#include "d3dengine.h"
-#include "camera.h"
-#include "sound.h"
+#include "graphics/d3d/d3dengine.h"
+#include "graphics/common/camera.h"
+#include "sound/sound.h"
class CInstanceManager;
@@ -777,5 +776,3 @@ protected:
float m_cmdLine[OBJECTMAXCMDLINE];
};
-
-#endif //_OBJECT_H_