summaryrefslogtreecommitdiffstats
path: root/src/plugins/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-19 16:52:11 +0100
committerDidier Raboud <odyx@debian.org>2012-12-19 16:52:17 +0100
commit3c976c040b48caa9f3e75d12a6502e39193ce9a6 (patch)
tree84274fd4718d78613beb1b92e4cbb51e64e1fefc /src/plugins/test/CMakeLists.txt
parentfec2c1028a7d0f46f38c985c18d8cf778456f643 (diff)
downloadcolobot-3c976c040b48caa9f3e75d12a6502e39193ce9a6.tar.gz
colobot-3c976c040b48caa9f3e75d12a6502e39193ce9a6.tar.bz2
colobot-3c976c040b48caa9f3e75d12a6502e39193ce9a6.zip
Don't enforce CMake build type on users.
Only set CMAKE_BUILD_TYPE to Debug when no value is provided.
Diffstat (limited to 'src/plugins/test/CMakeLists.txt')
-rw-r--r--src/plugins/test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/plugins/test/CMakeLists.txt b/src/plugins/test/CMakeLists.txt
index a68de2c..ff4f67b 100644
--- a/src/plugins/test/CMakeLists.txt
+++ b/src/plugins/test/CMakeLists.txt
@@ -1,6 +1,8 @@
cmake_minimum_required(VERSION 2.8)
-set(CMAKE_BUILD_TYPE debug)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11 -rdynamic")
add_executable(manager_test manager_test.cpp ../../common/logger.cpp ../../common/profile.cpp ../../common/iman.cpp ../pluginmanager.cpp ../pluginloader.cpp)