summaryrefslogtreecommitdiffstats
path: root/src/plugins/test/CMakeLists.txt
diff options
context:
space:
mode:
authorerihel <erihel@gmail.com>2012-07-19 19:19:21 +0200
committererihel <erihel@gmail.com>2012-07-19 19:19:21 +0200
commitd56db5f4e4a8e0d572bf3d682619bb25aebe4120 (patch)
treebb670182f3273a5a3bb18969cf8f25023fa381f0 /src/plugins/test/CMakeLists.txt
parent0e4b070b5f10c0004cfbfa234e3634357b070cba (diff)
downloadcolobot-d56db5f4e4a8e0d572bf3d682619bb25aebe4120.tar.gz
colobot-d56db5f4e4a8e0d572bf3d682619bb25aebe4120.tar.bz2
colobot-d56db5f4e4a8e0d572bf3d682619bb25aebe4120.zip
* Chaned plugin interface
* Added plugin class for plugin loading * Added plugin loading test
Diffstat (limited to 'src/plugins/test/CMakeLists.txt')
-rw-r--r--src/plugins/test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/plugins/test/CMakeLists.txt b/src/plugins/test/CMakeLists.txt
new file mode 100644
index 0000000..551daeb
--- /dev/null
+++ b/src/plugins/test/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.8)
+
+set(CMAKE_BUILD_TYPE debug)
+set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11 -rdynamic")
+
+add_executable(plugin_test plugin_test.cpp ../../common/iman.cpp ../../common/logger.cpp ../plugin.cpp)
+
+# Change to DirectX SDK directory
+include_directories("../../")
+
+target_link_libraries(plugin_test ltdl) \ No newline at end of file