summaryrefslogtreecommitdiffstats
path: root/src/po/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-27 13:52:47 +0100
committerDidier Raboud <odyx@debian.org>2012-12-27 13:52:47 +0100
commit877774a22601e7feb36013d25e6aaf8fe81b15bc (patch)
treecfd404e955b57a98b465e15887193ad9a1445dc6 /src/po/CMakeLists.txt
parent70cb629cc5728398e177c9b6bb7548847ce0be28 (diff)
downloadcolobot-877774a22601e7feb36013d25e6aaf8fe81b15bc.tar.gz
colobot-877774a22601e7feb36013d25e6aaf8fe81b15bc.tar.bz2
colobot-877774a22601e7feb36013d25e6aaf8fe81b15bc.zip
Update translation pot-file and build-target
Diffstat (limited to 'src/po/CMakeLists.txt')
-rw-r--r--src/po/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/po/CMakeLists.txt b/src/po/CMakeLists.txt
index 3b26571..df667dd 100644
--- a/src/po/CMakeLists.txt
+++ b/src/po/CMakeLists.txt
@@ -6,14 +6,13 @@ find_program(XGETTEXT_CMD xgettext)
add_custom_command(OUTPUT ${_potFile}
COMMAND ${XGETTEXT_CMD} ../app/app.cpp --output=${_potFile}
- COMMAND ${XGETTEXT_CMD} ../common/restext_strings.c --output=${_potFile} --join-existing --extract-all --no-location
+ COMMAND ${XGETTEXT_CMD} ../common/restext.cpp --output=${_potFile} --join-existing --extract-all --no-location
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Extract translatable messages to ${_potFile}"
)
-add_custom_target(_${potFile} ${_all} DEPENDS ${_potFile})
+add_custom_target(update-pot DEPENDS ${_potFile})
file(GLOB _poFiles *.po)
-
gettext_create_translations(${_potFile} ALL ${_poFiles})