summaryrefslogtreecommitdiffstats
path: root/src/script/cbottoken.cpp
diff options
context:
space:
mode:
authorMichał Konopacki <konopacki.m@gmail.com>2012-09-15 16:35:48 +0200
committerMichał Konopacki <konopacki.m@gmail.com>2012-09-15 16:35:48 +0200
commitd439f4fa93eb45175dcdfa773af8f68efa1bad9d (patch)
treea2620bee6aae9ee49726892c5d1ebe717ad88e33 /src/script/cbottoken.cpp
parente57be247c2ddce796fd64e9f3c1b3bfa4759b74a (diff)
parente9fcec9de52471508933c9d90cc6041ce0af9752 (diff)
downloadcolobot-d439f4fa93eb45175dcdfa773af8f68efa1bad9d.tar.gz
colobot-d439f4fa93eb45175dcdfa773af8f68efa1bad9d.tar.bz2
colobot-d439f4fa93eb45175dcdfa773af8f68efa1bad9d.zip
Merge branch 'dev-ui' into dev
Conflicts: src/CMakeLists.txt src/common/misc.cpp src/common/misc.h src/object/robotmain.cpp src/object/robotmain.h src/script/cbottoken.cpp src/script/cbottoken.h src/ui/button.cpp src/ui/button.h src/ui/check.cpp src/ui/check.h src/ui/color.cpp src/ui/color.h src/ui/compass.cpp src/ui/compass.h src/ui/control.cpp src/ui/control.h src/ui/displayinfo.cpp src/ui/displayinfo.h src/ui/displaytext.cpp src/ui/displaytext.h src/ui/edit.cpp src/ui/edit.h src/ui/gauge.cpp src/ui/gauge.h src/ui/interface.cpp src/ui/interface.h src/ui/key.cpp src/ui/map.h src/ui/shortcut.h src/ui/slider.h src/ui/target.cpp src/ui/target.h src/ui/window.cpp src/ui/window.h
Diffstat (limited to 'src/script/cbottoken.cpp')
-rw-r--r--src/script/cbottoken.cpp10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/script/cbottoken.cpp b/src/script/cbottoken.cpp
index b0bf67b..4d33bca 100644
--- a/src/script/cbottoken.cpp
+++ b/src/script/cbottoken.cpp
@@ -33,7 +33,7 @@
// Seeking the name of an object.
-const char* GetObjectName(ObjectType type)
+char* GetObjectName(ObjectType type)
{
if ( type == OBJECT_PORTICO ) return "Portico";
if ( type == OBJECT_BASE ) return "SpaceShip";
@@ -126,7 +126,7 @@ const char* GetObjectName(ObjectType type)
// Seeking the name of a secondary object.
// (because Otto thinks that Germans do not like nuclear power)
-const char* GetObjectAlias(ObjectType type)
+char* GetObjectAlias(ObjectType type)
{
if ( type == OBJECT_NUCLEAR ) return "FuelCellPlant";
if ( type == OBJECT_URANIUM ) return "PlatinumOre";
@@ -139,7 +139,7 @@ const char* GetObjectAlias(ObjectType type)
// Returns the help file to use for the object.
-const char* GetHelpFilename(ObjectType type)
+char* GetHelpFilename(ObjectType type)
{
if ( type == OBJECT_BASE ) return "help\\object\\base.txt";
if ( type == OBJECT_DERRICK ) return "help\\object\\derrick.txt";
@@ -224,7 +224,7 @@ const char* GetHelpFilename(ObjectType type)
// Returns the help file to use for instruction.
-const char* GetHelpFilename(const char *token)
+char* GetHelpFilename(const char *token)
{
if ( strcmp(token, "if" ) == 0 ) return "help\\cbot\\if.txt";
if ( strcmp(token, "else" ) == 0 ) return "help\\cbot\\if.txt";
@@ -436,7 +436,7 @@ bool IsFunction(const char *token)
// Returns using a compact instruction.
-const char* GetHelpText(const char *token)
+char* GetHelpText(const char *token)
{
if ( strcmp(token, "if" ) == 0 ) return "if ( condition ) { bloc }";
if ( strcmp(token, "else" ) == 0 ) return "else { bloc }";