summaryrefslogtreecommitdiffstats
path: root/src/sound/oalsound/CMakeLists.txt
diff options
context:
space:
mode:
authorerihel <erihel@gmail.com>2012-12-20 20:59:11 +0100
committererihel <erihel@gmail.com>2012-12-20 20:59:11 +0100
commita6ff654ae37ca372d785c1e155fbfe67a3a25fed (patch)
treec65408f7219e22b106a38c120fe671dc2a995e9c /src/sound/oalsound/CMakeLists.txt
parentf77734e01c85aded92cf5fdc1e7038658e6aaf29 (diff)
downloadcolobot-a6ff654ae37ca372d785c1e155fbfe67a3a25fed.tar.gz
colobot-a6ff654ae37ca372d785c1e155fbfe67a3a25fed.tar.bz2
colobot-a6ff654ae37ca372d785c1e155fbfe67a3a25fed.zip
removing plugins for gold version (for mxe cross compiling)
Diffstat (limited to 'src/sound/oalsound/CMakeLists.txt')
-rw-r--r--src/sound/oalsound/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/sound/oalsound/CMakeLists.txt b/src/sound/oalsound/CMakeLists.txt
new file mode 100644
index 0000000..bb7e9ff
--- /dev/null
+++ b/src/sound/oalsound/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 2.8)
+
+set(SOURCES
+ alsound.cpp
+ buffer.cpp
+ channel.cpp
+)
+
+SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++0x -fPIC")
+SET (CMAKE_CXX_FLAGS_DEBUG "-g")
+
+include(FindPkgConfig)
+include(FindOpenAL)
+pkg_check_modules(OPENAL_LIB REQUIRED openal)
+
+set(OPENAL_LIBRARIES
+ openal
+ alut
+)
+
+include_directories(../../..)
+include_directories(.)
+add_library(openalsound SHARED ${SOURCES})
+target_link_libraries(openalsound ${OPENAL_LIBRARIES})