summaryrefslogtreecommitdiffstats
path: root/src/sound/plugins/oalsound/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwiński <piotrdz@gmail.com>2012-08-12 10:15:19 -0700
committerPiotr Dziwiński <piotrdz@gmail.com>2012-08-12 10:15:19 -0700
commit50deedb6cbc927f6c7d6c3c5e9134d11c20782ae (patch)
tree8eb3fbd914cfea11660534b296bfddcffcc5f7b4 /src/sound/plugins/oalsound/test/CMakeLists.txt
parentbc24b9f9e516e657fcc0034808e010287fc2e393 (diff)
parent62b545128f37746c343760e464872655b5523c6f (diff)
downloadcolobot-50deedb6cbc927f6c7d6c3c5e9134d11c20782ae.tar.gz
colobot-50deedb6cbc927f6c7d6c3c5e9134d11c20782ae.tar.bz2
colobot-50deedb6cbc927f6c7d6c3c5e9134d11c20782ae.zip
Merge pull request #36 from Erihel/dev
Merge of new features: plugins and INI profile, changes from dev-graphics
Diffstat (limited to 'src/sound/plugins/oalsound/test/CMakeLists.txt')
-rw-r--r--src/sound/plugins/oalsound/test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/sound/plugins/oalsound/test/CMakeLists.txt b/src/sound/plugins/oalsound/test/CMakeLists.txt
new file mode 100644
index 0000000..d10169b
--- /dev/null
+++ b/src/sound/plugins/oalsound/test/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.8)
+
+set(CMAKE_BUILD_TYPE debug)
+set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11 -rdynamic")
+
+add_executable(plugin_test plugin_test.cpp ../../../../common/iman.cpp ../../../../common/logger.cpp ../../../../plugins/pluginloader.cpp)
+
+include_directories(".")
+include_directories("../../../../")
+
+target_link_libraries(plugin_test ltdl)