summaryrefslogtreecommitdiffstats
path: root/src/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-08-31 20:55:16 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-08-31 20:55:16 +0200
commite94e26ae1eb0dd8a3838e66db3abe4006d377ab2 (patch)
tree8fbab79952db846311dcfaf9ca149fc2e06805de /src/tools/CMakeLists.txt
parent3e52ae4ca9e27607b5691da0edbf3454e5e6099b (diff)
downloadcolobot-e94e26ae1eb0dd8a3838e66db3abe4006d377ab2.tar.gz
colobot-e94e26ae1eb0dd8a3838e66db3abe4006d377ab2.tar.bz2
colobot-e94e26ae1eb0dd8a3838e66db3abe4006d377ab2.zip
New model file format
- added new binary and text formats for models - fixes and improvements in CModelFile - tool for converting model files - minor additions and fixes
Diffstat (limited to 'src/tools/CMakeLists.txt')
-rw-r--r--src/tools/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/tools/CMakeLists.txt b/src/tools/CMakeLists.txt
new file mode 100644
index 0000000..f6c6112
--- /dev/null
+++ b/src/tools/CMakeLists.txt
@@ -0,0 +1,13 @@
+set(CONVERT_MODEL_SOURCES
+../common/iman.cpp
+../common/logger.cpp
+../common/stringutils.cpp
+../graphics/engine/modelfile.cpp
+convert_model.cpp
+)
+
+include_directories(. ..)
+
+add_definitions(-DMODELFILE_NO_ENGINE)
+
+add_executable(convert_model ${CONVERT_MODEL_SOURCES})