summaryrefslogtreecommitdiffstats
path: root/src/ui/maindialog.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-10 00:18:08 +0200
commit680af178196217bdd255d2bc851f240983144ac1 (patch)
tree77d713bace78c1becb1c96a2b36dd09e44d8d330 /src/ui/maindialog.h
parentd6525b5661c364a46514aaa772c090ecb0bfd26c (diff)
downloadcolobot-680af178196217bdd255d2bc851f240983144ac1.tar.gz
colobot-680af178196217bdd255d2bc851f240983144ac1.tar.bz2
colobot-680af178196217bdd255d2bc851f240983144ac1.zip
Fixed include paths and CMakeLists.txt
Additionally, changed #ifndef to #pragma once everywhere
Diffstat (limited to 'src/ui/maindialog.h')
-rw-r--r--src/ui/maindialog.h11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/ui/maindialog.h b/src/ui/maindialog.h
index 21dca18..fbc3f1e 100644
--- a/src/ui/maindialog.h
+++ b/src/ui/maindialog.h
@@ -16,12 +16,12 @@
// maindialog.h
-#ifndef _MAINDIALOG_H_
-#define _MAINDIALOG_H_
+#pragma once
-#include "struct.h"
-#include "camera.h"
-#include "robotmain.h"
+
+#include "common/struct.h"
+#include "graphics/common/camera.h"
+#include "object/robotmain.h"
class CInstanceManager;
@@ -253,4 +253,3 @@ protected:
};
-#endif //_MAINDIALOG_H_