summaryrefslogtreecommitdiffstats
path: root/src
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-12-16 13:22:58 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2012-12-16 13:22:58 +0100
commit56a170391f944f7a042b81fe7e6817a0c28fb005 (patch)
tree6a4d1adaf2a094d98852e77e7178713884a5b66a /src
parent72ce040054f1ee20576094220075af4283674720 (diff)
downloadcolobot-56a170391f944f7a042b81fe7e6817a0c28fb005.tar.gz
colobot-56a170391f944f7a042b81fe7e6817a0c28fb005.tar.bz2
colobot-56a170391f944f7a042b81fe7e6817a0c28fb005.zip
Split gtest and gmock, fixed using system packages
- split the bundled gtest and gmock libraries - allowed the use of system gmock - refactoring in CMakeLists
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/common/test/CMakeLists.txt2
-rw-r--r--src/graphics/engine/test/CMakeLists.txt2
-rw-r--r--src/math/test/CMakeLists.txt2
-rw-r--r--src/ui/test/CMakeLists.txt3
5 files changed, 6 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e836d95..4ffacd3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -195,4 +195,4 @@ add_executable(colobot ${SOURCES})
target_link_libraries(colobot ${LIBS})
-INSTALL_TARGETS(/games colobot)
+install_targets(/games colobot)
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index ccbb739..08efdb3 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -7,7 +7,7 @@ include_directories(
.
../..
../../..
-${GTEST_DIR}/include
+${GTEST_INCLUDE_DIR}
)
diff --git a/src/graphics/engine/test/CMakeLists.txt b/src/graphics/engine/test/CMakeLists.txt
index 4e3263b..775abe5 100644
--- a/src/graphics/engine/test/CMakeLists.txt
+++ b/src/graphics/engine/test/CMakeLists.txt
@@ -16,7 +16,7 @@ add_definitions(-DMODELFILE_NO_ENGINE)
include_directories(
.
../../..
-${GTEST_DIR}/include
+${GTEST_INCLUDE_DIR}
)
add_executable(modelfile_test ${MODELFILE_TEST_SOURCES})
diff --git a/src/math/test/CMakeLists.txt b/src/math/test/CMakeLists.txt
index 8588bd1..5bc9027 100644
--- a/src/math/test/CMakeLists.txt
+++ b/src/math/test/CMakeLists.txt
@@ -7,7 +7,7 @@ include_directories(
.
../..
../../..
-${GTEST_DIR}/include
+${GTEST_INCLUDE_DIR}
)
add_executable(matrix_test matrix_test.cpp)
diff --git a/src/ui/test/CMakeLists.txt b/src/ui/test/CMakeLists.txt
index 9e11e14..7562a04 100644
--- a/src/ui/test/CMakeLists.txt
+++ b/src/ui/test/CMakeLists.txt
@@ -7,7 +7,8 @@ include_directories(
.
../..
../../..
-${GTEST_DIR}/include
+${GTEST_INCLUDE_DIR}
+${GMOCK_INCLUDE_DIR}
)