summaryrefslogtreecommitdiffstats
path: root/test/envs/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-02-03 20:03:36 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2013-02-03 20:03:36 +0100
commit209c6412ae149cc7c503fd7da384f344a830423c (patch)
tree5baeaeb8dee2208b46bf80a118dfe59eb65f9389 /test/envs/opengl/CMakeLists.txt
parent3f41f97fc47fca22634dc858c3ecdb39d0d27e32 (diff)
downloadcolobot-209c6412ae149cc7c503fd7da384f344a830423c.tar.gz
colobot-209c6412ae149cc7c503fd7da384f344a830423c.tar.bz2
colobot-209c6412ae149cc7c503fd7da384f344a830423c.zip
Refactoring in tests infrastructure
* all tests are now in /test/ subdirectory * unit tests concatenated to one executable (TODO: ui, common) * preparation for test environments (OpenGL and others) * removed old TestCBot
Diffstat (limited to 'test/envs/opengl/CMakeLists.txt')
-rw-r--r--test/envs/opengl/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/test/envs/opengl/CMakeLists.txt b/test/envs/opengl/CMakeLists.txt
new file mode 100644
index 0000000..588a864
--- /dev/null
+++ b/test/envs/opengl/CMakeLists.txt
@@ -0,0 +1,63 @@
+set(SRC_DIR ${colobot_SOURCE_DIR}/src)
+
+configure_file(${SRC_DIR}/common/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/common/config.h)
+
+
+set(TEXTURE_SOURCES
+${SRC_DIR}/graphics/opengl/gldevice.cpp
+${SRC_DIR}/common/logger.cpp
+${SRC_DIR}/common/image.cpp
+texture_test.cpp
+)
+
+set(MODEL_SOURCES
+${SRC_DIR}/graphics/opengl/gldevice.cpp
+${SRC_DIR}/graphics/engine/modelfile.cpp
+${SRC_DIR}/common/logger.cpp
+${SRC_DIR}/common/image.cpp
+${SRC_DIR}/common/iman.cpp
+${SRC_DIR}/common/stringutils.cpp
+${SRC_DIR}/app/system.cpp
+model_test.cpp
+)
+
+set(TRANSFORM_SOURCES
+${SRC_DIR}/graphics/opengl/gldevice.cpp
+${SRC_DIR}/common/logger.cpp
+${SRC_DIR}/common/image.cpp
+${SRC_DIR}/common/iman.cpp
+${SRC_DIR}/app/system.cpp
+transform_test.cpp
+)
+
+set(LIGHT_SOURCES
+${SRC_DIR}/graphics/opengl/gldevice.cpp
+${SRC_DIR}/common/logger.cpp
+${SRC_DIR}/common/image.cpp
+${SRC_DIR}/common/iman.cpp
+${SRC_DIR}/app/system.cpp
+light_test.cpp
+)
+
+include_directories(${SRC_DIR} ${CMAKE_CURRENT_BINARY_DIR})
+
+set(LIBS
+${SDL_LIBRARY}
+${SDLIMAGE_LIBRARY}
+${OPENGL_LIBRARY}
+${GLEW_LIBRARY}
+${PNG_LIBRARIES}
+${ADD_LIBS}
+)
+
+add_executable(texture_test ${TEXTURE_SOURCES})
+target_link_libraries(texture_test ${LIBS})
+
+add_executable(model_test ${MODEL_SOURCES})
+target_link_libraries(model_test ${LIBS})
+
+add_executable(transform_test ${TRANSFORM_SOURCES})
+target_link_libraries(transform_test ${LIBS})
+
+add_executable(light_test ${LIGHT_SOURCES})
+target_link_libraries(light_test ${LIBS})