summaryrefslogtreecommitdiffstats
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2013-11-27 18:53:28 +0100
committerDidier Raboud <odyx@debian.org>2013-11-27 18:53:28 +0100
commit343fa8f0cbad19402a2533651acc53149be1fcf5 (patch)
treea4fb835948e3d995d42ac353de72a55433673b82 /test/unit/CMakeLists.txt
parent8c25650ad5e888019f350f099d6755921780c6f1 (diff)
downloadcolobot-343fa8f0cbad19402a2533651acc53149be1fcf5.tar.gz
colobot-343fa8f0cbad19402a2533651acc53149be1fcf5.tar.bz2
colobot-343fa8f0cbad19402a2533651acc53149be1fcf5.zip
Add a PLATFORM_GNU global variable matching all GNU systems such as Debian's Linux, kFreeBSD and Hurd
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 38bffda..278519f 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -6,6 +6,8 @@ if(MXE) # MXE requires special treatment
elseif(PLATFORM_WINDOWS)
# because it isn't included in standard linking libraries
set(PLATFORM_LIBS "-lintl")
+elseif(PLATFORM_GNU)
+ set(PLATFORM_LIBS "-lX11")
elseif(PLATFORM_LINUX)
# for clock_gettime
set(PLATFORM_LIBS "-lrt -lX11")