summaryrefslogtreecommitdiffstats
path: root/test/unit
diff options
context:
space:
mode:
authorDidier 'OdyX' Raboud <didier@raboud.com>2013-11-20 10:39:06 +0100
committerDidier 'OdyX' Raboud <didier@raboud.com>2013-11-20 10:39:06 +0100
commit89e2855f9577a629d1ca67e87de588815829864e (patch)
tree66e5548d25312c99a74b55b33a2fd57c96f0200e /test/unit
parent4e2ac61ee6c4d95c4846bce2ca29022083876347 (diff)
downloadcolobot-89e2855f9577a629d1ca67e87de588815829864e.tar.gz
colobot-89e2855f9577a629d1ca67e87de588815829864e.tar.bz2
colobot-89e2855f9577a629d1ca67e87de588815829864e.zip
Consolidate SYSTEM_CPP_MODULE in the main CMakeLists.txt
Diffstat (limited to 'test/unit')
-rw-r--r--test/unit/CMakeLists.txt10
-rw-r--r--test/unit/ui/CMakeLists.txt5
2 files changed, 2 insertions, 13 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 1f5e1bc..38bffda 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -18,20 +18,12 @@ endif()
# Configure file
configure_file(${SRC_DIR}/common/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/common/config.h)
-# Platform-dependent implementation of system.h
-if(PLATFORM_WINDOWS)
- set(SYSTEM_CPP_MODULE "system_windows.cpp")
-elseif(PLATFORM_LINUX)
- set(SYSTEM_CPP_MODULE "system_linux.cpp")
-else()
- set(SYSTEM_CPP_MODULE "system_other.cpp")
-endif()
-
# Code sources
set(COLOBOT_SOURCES
${SRC_DIR}/app/app.cpp
${SRC_DIR}/app/system.cpp
${SRC_DIR}/app/${SYSTEM_CPP_MODULE}
+${SRC_DIR}/app/system_other.cpp
${SRC_DIR}/common/event.cpp
${SRC_DIR}/common/image.cpp
${SRC_DIR}/common/iman.cpp
diff --git a/test/unit/ui/CMakeLists.txt b/test/unit/ui/CMakeLists.txt
index 97dd681..8086967 100644
--- a/test/unit/ui/CMakeLists.txt
+++ b/test/unit/ui/CMakeLists.txt
@@ -10,21 +10,18 @@ ${CLIPBOARD_INCLUDE_DIR}
# Platform-dependent implementation of CSystemUtils
if(PLATFORM_WINDOWS)
- set(SYSTEM_CPP_MODULE "system_windows.cpp")
elseif(PLATFORM_LINUX)
- set(SYSTEM_CPP_MODULE "system_linux.cpp")
set(ADDITIONAL_LIB "-lX11")
elseif(PLATFORM_MACOSX)
- set(SYSTEM_CPP_MODULE "system_other.cpp")
set(ADDITIONAL_LIB "${X11_X11_LIB}")
else()
- set(SYSTEM_CPP_MODULE "system_other.cpp")
set(ADDITIONAL_LIB "-lX11")
endif()
add_executable(edit_test
${SRC_DIR}/app/system.cpp
${SRC_DIR}/app/${SYSTEM_CPP_MODULE}
+${SRC_DIR}/app/system_other.cpp
${SRC_DIR}/common/event.cpp
${SRC_DIR}/common/logger.cpp
${SRC_DIR}/common/misc.cpp