summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.travis.yml6
-rw-r--r--debian/changelog5
-rw-r--r--debian/colobot-common.install2
-rw-r--r--debian/colobot-dev-doc.doc-base10
-rw-r--r--debian/colobot-dev-doc.install1
-rw-r--r--debian/colobot-dev-doc.links1
-rw-r--r--debian/colobot.install9
-rw-r--r--debian/compat1
-rw-r--r--debian/control83
-rwxr-xr-xdebian/rules25
-rw-r--r--debian/source/format1
11 files changed, 142 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index af27ea3..71720b2 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,11 +2,13 @@ language: cpp
compiler:
- gcc
- clang
-script: mkdir build; cd build; cmake .. -DCMAKE_VERBOSE_MAKEFILE=ON && make all doc test && DESTDIR=. make install
+script: debuild -b -us -uc --lintian-opts "-ivI"
before_install:
- git submodule update --init --recursive
- sudo add-apt-repository ppa:mapnik/boost -y
- sudo apt-get update -qq
- - sudo apt-get install -qq --no-install-recommends libgl1-mesa-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-ttf2.0-dev libpng12-dev libglew-dev libboost-dev libboost-system-dev libboost-filesystem-dev libboost-regex-dev google-mock libgtest-dev doxygen graphviz po4a librsvg2-bin libsndfile-dev
+ - sudo apt-get install -qq --no-install-recommends devscripts dpkg-dev lintian equivs
+ - mk-build-deps --root-cmd sudo --tool "apt-get -qq --no-install-recommends" --install --remove
+ - dch -b -v 0.1.0~git$(date +%Y%m%d%H%M)00-1~travis0 -m "Automated test-build."
notifications:
email: false
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..21873e3
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+colobot (0.1.0~pre-alpha-git-dev~r376-gb22d852-1~OdyX0) UNRELEASED; urgency=low
+
+ * Initial release. (Closes: #695829)
+
+ -- Didier Raboud <odyx@debian.org> Sun, 09 Jun 2013 19:01:36 +0200
diff --git a/debian/colobot-common.install b/debian/colobot-common.install
new file mode 100644
index 0000000..f050885
--- /dev/null
+++ b/debian/colobot-common.install
@@ -0,0 +1,2 @@
+usr/share/locale/*/LC_MESSAGES/colobot.mo
+usr/share/games/colobot/
diff --git a/debian/colobot-dev-doc.doc-base b/debian/colobot-dev-doc.doc-base
new file mode 100644
index 0000000..4f04362
--- /dev/null
+++ b/debian/colobot-dev-doc.doc-base
@@ -0,0 +1,10 @@
+Document: colobot-source-doc
+Title: Colobot source code documentation
+Author: Polish Portal of Colobot
+Abstract: This is the Doxygen-generated documentation of the Colobot
+ source code.
+Section: Programming
+
+Format: HTML
+Index: /usr/share/doc/colobot/html/index.html
+Files: /usr/share/doc/colobot/html/*.html
diff --git a/debian/colobot-dev-doc.install b/debian/colobot-dev-doc.install
new file mode 100644
index 0000000..4ae8eb0
--- /dev/null
+++ b/debian/colobot-dev-doc.install
@@ -0,0 +1 @@
+usr/share/doc/colobot/html
diff --git a/debian/colobot-dev-doc.links b/debian/colobot-dev-doc.links
new file mode 100644
index 0000000..76bf4e0
--- /dev/null
+++ b/debian/colobot-dev-doc.links
@@ -0,0 +1 @@
+usr/share/javascript/jquery/jquery.js usr/share/doc/colobot/html/jquery.js
diff --git a/debian/colobot.install b/debian/colobot.install
new file mode 100644
index 0000000..d1bedf6
--- /dev/null
+++ b/debian/colobot.install
@@ -0,0 +1,9 @@
+usr/lib/colobot/libCBot.so
+usr/games/colobot
+usr/share/applications/colobot.desktop
+usr/share/icons/hicolor/scalable/apps/colobot.svg
+usr/share/icons/hicolor/48x48/apps/colobot.png
+usr/share/icons/hicolor/32x32/apps/colobot.png
+usr/share/icons/hicolor/16x16/apps/colobot.png
+usr/share/man/man6/colobot.6
+usr/share/man/*/man6/colobot.6
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..3da5a55
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,83 @@
+Source: colobot
+Section: games
+Priority: optional
+Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
+Uploaders: Didier Raboud <odyx@debian.org>
+Build-Depends:
+ debhelper (>= 9),
+ cmake,
+ libgl1-mesa-dev | libgl-dev,
+ libglew-dev,
+ libsdl1.2-dev (>= 1.2.10),
+ libsdl-image1.2-dev,
+ libsdl-ttf2.0-dev,
+ libpng12-dev (>= 1.2),
+ libboost-dev,
+ libboost-system-dev,
+ libboost-filesystem-dev,
+ libboost-regex-dev,
+ libopenal-dev,
+ libsndfile-dev,
+ librsvg2-bin,
+ po4a,
+ perl,
+ google-mock,
+ libgtest-dev
+Build-Depends-Indep: doxygen, graphviz
+Standards-Version: 3.9.4
+Homepage: http://colobot.info
+
+Package: colobot
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ colobot-common (>= ${source:Version})
+Description: educational programming strategy game
+ Colobot (Colonize with Bots) is an educational game aiming to teach
+ programming through entertainment. You are playing as an astronaut on a
+ journey with robot helpers to find a planet for colonization. It features 3D
+ real-time graphics and a C++ and Java-like, object-oriented language, CBOT,
+ which can be used to program the robots available in the game.
+
+Package: colobot-common
+Architecture: all
+Depends: ${misc:Depends}
+Recommends: colobot (>= ${source:Version})
+Description: educational programming strategy game - data
+ Colobot (Colonize with Bots) is an educational game aiming to teach
+ programming through entertainment. You are playing as an astronaut on a
+ journey with robot helpers to find a planet for colonization. It features 3D
+ real-time graphics and a C++ and Java-like, object-oriented language, CBOT,
+ which can be used to program the robots available in the game.
+ .
+ This package contains the architecture-independent game data.
+
+Package: colobot-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: ${misc:Depends}, ${shlibs:Depends},
+ colobot (= ${binary:Version})
+Description: educational programming strategy game - debug symbols
+ Colobot (Colonize with Bots) is an educational game aiming to teach
+ programming through entertainment. You are playing as an astronaut on a
+ journey with robot helpers to find a planet for colonization. It features 3D
+ real-time graphics and a C++ and Java-like, object-oriented language, CBOT,
+ which can be used to program the robots available in the game.
+ .
+ This package contains the debugging symbols.
+
+Package: colobot-dev-doc
+Architecture: all
+Section: doc
+Depends: ${misc:Depends},
+ libjs-jquery
+Recommends: colobot (>= ${source:Version})
+Description: educational programming strategy game - source doc
+ Colobot (Colonize with Bots) is an educational game aiming to teach
+ programming through entertainment. You are playing as an astronaut on a
+ journey with robot helpers to find a planet for colonization. It features 3D
+ real-time graphics and a C++ and Java-like, object-oriented language, CBOT,
+ which can be used to program the robots available in the game.
+ .
+ This package contains the doxygen documentation for the colobot source code.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..5cb315b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ \
+ --buildsystem=cmake \
+ --parallel \
+ --dbg-package=colobot-dbg
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DCMAKE_BUILD_TYPE:STRING="RelWithDebInfo" \
+ -DINSTALL_DOCS:BOOL=True \
+ -DOPENAL_SOUND:BOOL=True
+
+override_dh_auto_build:
+ dh_auto_build -a
+ dh_auto_build -i -- doc
+
+merge-dev:
+ set -e; \
+ DEV_COMMIT=$$(git describe --tags dev | sed -e 's/^colobot-gold-pre_alpha-//g'); \
+ git merge --no-commit dev; \
+ dch -b -v 0.1.0~pre-alpha-git-dev~r$${DEV_COMMIT}-1~OdyX0 "New snapshot of dev branch ($${DEV_COMMIT})"; \
+ sed -e "/New snapshot of dev branch ($${DEV_COMMIT})/d" -i debian/changelog ; \
+ git add debian/changelog; \
+ git commit -m "New snapshot of dev branch ($${DEV_COMMIT})"
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)