summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--src/CBot/CMakeLists.txt2
-rw-r--r--src/CMakeLists.txt2
3 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1353250..660c79f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,3 +131,5 @@ endif()
# Subdirectory with sources
add_subdirectory(src bin)
+
+INSTALL_FILES(/share/games/colobot ../data)
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index 9f5b987..271f2ce 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -17,3 +17,5 @@ if(${CBOT_STATIC})
else()
add_library(CBot SHARED ${SOURCES})
endif()
+
+INSTALL_TARGETS(/lib CBot)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a7f1c96..c8372b0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -192,3 +192,5 @@ link_directories(${CMAKE_CURRENT_SOURCE_DIR}/CBot)
add_executable(colobot ${SOURCES})
target_link_libraries(colobot ${LIBS})
+
+INSTALL_TARGETS(/games colobot)