summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44c0a3f..82a6e80 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,14 +8,16 @@ project(colobot C CXX)
find_package(OpenGL REQUIRED)
find_package(SDL REQUIRED)
find_package(SDL_image REQUIRED)
+find_package(PNG REQUIRED)
+
+# TODO: check for SDL version. Should be >= 1.2.10
# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
-
# Global compile flags
set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -std=gnu++0x")
-set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0 -Wall -std=gnu++0x")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -std=gnu++0x")
# Subdirectory with sources
add_subdirectory(src bin)