summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02016af..ae0231d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,9 +1,15 @@
-# CMake project file for compiling with MinGW
+# CMake project file for compiling with GCC/MinGW
cmake_minimum_required(VERSION 2.8)
-project(colobot CXX)
+project(colobot C CXX)
+# Required packages
+find_package(OpenGL REQUIRED)
+find_package(SDL REQUIRED)
+find_package(SDL_image REQUIRED)
+
+# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
# Currently compiles only with -fpermissive
@@ -11,4 +17,5 @@ set(CMAKE_BUILD_TYPE debug)
set(CMAKE_CXX_FLAGS_RELEASE "-fpermissive -O2")
set(CMAKE_CXX_FLAGS_DEBUG "-fpermissive -w -g -O0")
+# Subdirectory with sources
add_subdirectory(src bin)