summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae0231d..2d24e0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,10 +12,9 @@ find_package(SDL_image REQUIRED)
# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
-# Currently compiles only with -fpermissive
-
-set(CMAKE_CXX_FLAGS_RELEASE "-fpermissive -O2")
-set(CMAKE_CXX_FLAGS_DEBUG "-fpermissive -w -g -O0")
+# Global compile flags
+set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0")
# Subdirectory with sources
add_subdirectory(src bin)